Lags/Latency due to TeamSpeak

Hello there,

I’m using TeamSpeak for several years now and have never had a problem like this before:

Several months ago (I don’t know exactly) I notices that I have a very significant delay in speaking from time to time. I speak into my microphone and the blue light turns on up to two seconds later.
I could always work around the problem by restarting the TeamSpeak client (disconnecting is not enough). After that, everything always worked again, for now.

I didn’t really deal with this problem until I also had performance issues in games or even in Windows directly. But I cannot guarantee this relationship one hundred percent.

What I do guarantee are the results of my diagnostics, which I ran with LatencyMon:
I am often online in TeamSpeak even when I am not talking to anyone. I have notices that the measured DPC latency increases over time the longer I use TeamSpeak. That doesn’t stop either. It can go up to tens of thousands of microseconds.

This is a screenshot of LatencyMon after only one hour of TeamSpeak usage (Pay attention to the current measured interrupt to DPC latency):

These are the values after I restarted TeamSpeak:

To solve the problem, I updated several drivers (chipset, Bluetooth, LAN and GPU), updated the BIOS to the latest stable version and reinstalled the TeamSpeak client.
Of course, none of this helped.

I also wanted to update the Realtek audio driver, but I did not find a download that is newer than 2017 on Realtek’s site.

The TeamSPeak version I use is: 3.5.6
Audio driver version is: 6.0.8960.1
Windows 10 Pro 20H2

Any ideas how to fix?

Hello @S1rDan,

Please try to disable the Echo reduction and Echo cancellation under Tools > Options > Capture


1 Like

So I was curious to go back and watch my latency with the program LatencyMon, what I noticed was a really annoying thing with Teamspeak 3.6.1/3.6.2 and TeamSpeak 5, NOTE (Tested on 3 different machines)
The conclusion is the same, when Teamspeak is started from a bare bone and brand new setup of Teamspeak and a fresh installation of windows 10/11 you will gain more than double Latency on your system and at worst it can cause the latency to raise it by x10 or more !

LatencyMon can be found here to test your self.

This is my system

Windows 11, Fresh installed yesterday, latest version public (22621.2283)
cpu 5950x
motherboard ROG Crosshair VIII Hero bios 4501
Nvidia founders edition 3080 GPU
Creative G6 usb soundcard.
TeamSpeak 3.6.1 stable and dark skin installed thats it.

I dont have any voice/mic filtering setup in teamspeak settings, completely plain default setup.

Here’s a video.

tldr ts3/ts5 causes huge latency increase from 10-20(µs) up to 120-150(µs)

Why was my post closed and merged into this thread?

I don’t have these things on, neither does the 2 other machines.

Okay so still no feedback from admins, I went away and tested version 3.5.6 64bit version it still went up from 10-20(µs) to around 50-70(µs) so its defiantly better than latest version 3.6.2 but still is bad compared to other chat/voices that does not do a jump at all when using their services.

I found the version in here.

Also it seems that whatever teamspeak is doing its not working well with the internal kernel driver, listed in the picture below.

This goes to the moon whenever teamspeaks gets started.

@TS.ChrisR Are we going to have somebody of any of you/developers look into this? or is this the last nail into teamspeak being abandoned?

Sadly we wont be using teamspeak anymore until this is fixed, at least for us in the competitive scene, already spread the news about this to the cores I play with, their findings is the same so its not a one of kind issue.

Just a few ideas…

  • Try disabling the news ticker in the TeamSpeak 3 status bar
  • If you’re in change of the TeamSpeak Server, try disabling the server banner or join a server without a banner and see if it makes a difference
  • Check which sound backend your client is using at SettingsOptionsCapture/PlaybackMode
    • If it’s either automatic or Direct Sound, please switch to Windows Audio Session for both capture and playback

I hope this helps. If the problem persists, consider exploring other troubleshooting steps like updating your device drivers.

Also, would be interesting to know if the same happens when you join a voice channel in Discord.