Local server worked once and now isn't showing on a servers list

Hi! I am new here and I have had some problems while trying to set up my local TS server so my brother and I can use TFAR mod in ARMA 3.But we managed to use it only once.I have installed the latest version of both TS3 client and TS3 server. I’ve set up my IP address to be static and I’ve port forwarded 9987. The method I used to connect was to install the TS3 server first and run it.Then I’ve connected to it (localy) by typing 127.0.0.1 to loop it back to my PC and went to port forwarding.When that was done I disconnected from 127.0.0.1 and connected by using my static IP address.When I went to see the server list I was on it and my brother could join.We stopped playing, I turned my PC off and tomorrow when I ran the server,started TS3 client afterwards and connected to it using my static IP, I could’t find myself on the server list nor my brother could.I’ve checked if port forwarding was correct etc. and everything was fine. I don’t know if this can make issues but I have created a new channel on my server and deleted the default one that day when I noticed it wasn’t working anymore.
If someone has some kind of solution for this I would be grateful.

P.S. While ingame I noticed that my brothers voice was repeating once after he spoke.The same sentence only louder,incomplete and way more annoying.And that was happening only while in game.I’ve done some research and wanted to try some of the solutions but I can’t because my server isn’t showing anymore.So if anyone has the first hand experience with this I would be grateful if provided with a concrete solution of that too.

Are you sure you’ve checked the “Report to weblist” on your virtual server settings?
Are you sure you’ve opened the required ports to use the weblist?

Domain Protocol Local Port (Server) Remote Port Notes
weblist.teamspeak.com UDP 2011-2110 (first available) 2010 all server versions
1 Like

a little confused about what you mean by “static ip” however on local network you are only able to connect via the local network ip, which is usually something like 192.168.1.100, you have to check it for yourself. if thats what you did before, your local ip address has likely changed and thats why you cant connect anymore.

the loopback happened on teamspeak or in game? either way its probably due to a bad mic or bad settings in either windows or the game. disable all mic enhancement settings in windows, in your headphones software etc, honestly no idea what causes it specifically

edit: i quickly ran through your post the first time, now realized you have a different problem. have you tried to search for your servers name, filtering by country, etc? it should be there, at least for me it works instantly whenever i enable or disable, on vps and home server too, having only the basic ports forwarded.

twitch instagram twitter facebook