Local Teamspeak server won't run after update to 3.12.1

I followed the normal instructions of downloading the new server files, and then copied them into the directory where my server is and overwriting the old files. I run the server and can connect to localhost, but no other users can connect now. The ports are still forwarded and I’ve tried rebooting the router just in case. Below is the log when I run it:

2020-05-16 07:44:30.523482|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.12.1 (2020-03-27 10:38:47)
2020-05-16 07:44:30.523482|INFO |ServerLibPriv | |SystemInformation: Windows 10 (18363) x64 (AMD or Intel) Binary: 64bit
2020-05-16 07:44:30.523482|INFO |ServerLibPriv | |Using hardware aes
2020-05-16 07:44:30.543328|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2020-05-16 07:44:30.543328|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2020-05-16 07:44:30.544325|INFO |DatabaseQuery | |checking database integrity (may take a while)
2020-05-16 07:44:30.566244|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2020-05-16 07:44:30.569236|INFO |Accounting | |Licensing Information
2020-05-16 07:44:30.569236|INFO |Accounting | |licensed to : Anonymous
2020-05-16 07:44:30.569236|INFO |Accounting | |type : No License
2020-05-16 07:44:30.569236|INFO |Accounting | |starting date : Sat Feb 1 00:00:00 2020
2020-05-16 07:44:30.569236|INFO |Accounting | |ending date : Mon Feb 1 00:00:00 2021
2020-05-16 07:44:30.569236|INFO |Accounting | |max virtualservers: 1
2020-05-16 07:44:30.569236|INFO |Accounting | |max slots : 32
2020-05-16 07:44:31.668492|INFO | | |Puzzle precompute time: 1082
2020-05-16 07:44:31.669490|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
2020-05-16 07:44:31.720358|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
2020-05-16 07:44:31.721362|INFO |Query | |listening for ssh query on 0.0.0.0:10022, [::]:10022
2020-05-16 07:44:31.721362|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32,
2020-05-16 07:44:31.821458|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated

Unsure of how to resolve the fact that there is “No License”, as it appears it is still looking for “licensekey.dat”, and the embedded license does not appear to be taking effect. I have deleted the “.ts3server_license_accepted”, recreated it manually, and deleted it and then ran the server and re-accepted the license when prompted.

I have tried downloading the server files again, unzipping, and then running a brand new server from that folder as well, and even that one appears to be giving me the licensing error.

That’s no error as it’s category is called WARNING.

If you don’t own a license the server can’t use one, right?
That’s why the server falls back to it’s 32 slots limit.

There’s nothing wrong inside this log.

Let’s find out why your server isn’t running.


(edit)

Ow… my bad.

SystemInformation: Windows 10 (18363) x64 (AMD or Intel) Binary: 64bit

I wonder about your Puzzle precompute time.

Which CPU does your system use?
Did you allow the TeamSpeak server to pass your firewall?
Did your public IP address change your friends may don’t know?

1 Like

I’m using an i7-8700K @3.7
Yes I did, I had the server running previously and everything was already allowed
I’m testing via my phone and my IP address has not changed.

Alright.
What exactly happens after you start the server?

Local Teamspeak server won’t run after update

Is the application running or not?
(take a look into the task manager)

Is it still possible to connect locally?

I apologize, the title was not totally accurate. The server does run, I can see the task in my task manager. I can also connect locally, it was mentioned above.

Figured it out, my IPv4 rolled and I had to change the port forwarding. I feel real dumb. Thanks for trying so hard. Had a real ID10T there.

twitch instagram twitter facebook