Mic sound is played back on headphones - how to disable?

I want to use my bluetooth headphones (Galaxy Buds+) with TS3 but as soon as I start the app, they also play back the mic’s audio, kind of like the “ambient mode” headphones with ANC come with does (the Buds+ don’t have ANC), and I can hear myself type on my keyboard, click the mouse and talk really loud. As soon as I close TS, it stops, and this also doesn’t happen with my wired headset (that I can’t use at the moment).

This thread on the old forums asked the same question but “listen to this device” is already unticked for me (Win 10).

How do I disable this weird mic playback?