Microphone increases as I talk TS3

I’m trying to set up my TeamSpeak and, for some reason, my mic grows louder as I talk. I use a blue snowball and voicemeeter banana which works perfectly with everything else other than ts. Any help would be greatly appreciated.

2 Likes

I have the same issue, older versions e.g. from 2017 had special feature called: Automatic voice gain control, after you disable it, it solved issue.
In this newest version you could not find that and it SHOULD BE IMPLEMENTED for people which could have problems like we.
If not, tell me about workaround to solve that issue.
THX

2 Likes

Um, AGC is in latest TS3 Client. It just was moved from recording to playback in 3.5.0 and probably something went wrong while doing that.

One half of people complain that now mics are broken, second half says there’s nothing wrong. TeamSpeak knows about this problem and AFAIK are fixing it, but right now it may take longer then usual.

Thanks for feedback. Yesterday I downgrade my TeamSpeak to older version -> 3.3.2 which have this AGC in Capture. I was afraid that nevertheless I will not be able to connect to any server as I am using not current version, but I was surprised and it works. So my suggestion for now is to use that version till TS Team will not implement some solution for higher versions.

Thanks.

It has rendered TS absolutely useless and I am under the impression this was intentional. It’s like they are about to commit app suicide. I am not sticking around if an update doesn’t fix that soon. My last session with my brother was literally a ear r*pe fest. I’m not even bothering to find an older version. I even bought the mobile version to support the app. I have had my voice server for ages. If they decided that it will not have VGC then I’m out. Guess I’ll stick to Discord.

When I start talking my volume will be low then slowly increase being too loud, I can’t find a setting that affects this at all

Because there is none setting or feature doing this.
There is only AGC in playback and this changes the loudness of a speaking user for your client.

1 Like

Hello all,

since some recent Version the option to completely disable the Automatic Gain Control ‘Feature’ seems to be missing from the Recording options.
Is there any other way to completely disable Automatic Gain Control of the Microphone on my ‘side’?
The corresponding Option in the Playback Options does not help.

Best Regards

You already found out…
There is no gain control on your end. The gain control is on the receivers end. It’s up to them to regulate your volume. If they don’t want you to be automatically adjusted they have to turn of AGC not you.

2 Likes

Hello,
thanks for your reply.
I can clearly hear the microphone level adjusting to insane values when testing the input (Capture -> Begin Test). As a result, sometimes it’s way too loud and sometimes it’s way too quiet. Happens with multiple fairly decent microphones.
In all honesty, this is just a crap feature and/or crap algorithm and i don’t understand why the option got removed in the first place.

2 Likes

for the love of god, please please please bring back the option to disable all kinds of Automatic Gain Control ‘features’ on my local recording end.

Suppose there are background noises and im not talking for a longer period of time, the gain is boosted to insane levels, thus the background noises are just as loud as my normal voice would be. how is this even considered a useful feature, whats the decision process behind this?

is it possible to get an official statement from the devs on this matter? its so annoying and mind-boggling.

Best Regards

As Gamer92000 said. There is none!
We do not touch your microphone level!

Local Test uses Playback AGC.

2 Likes

@TS.ChrisR thank you for the clarification!

Does the local test use Playback AGC even if i disabled Playback AGC in my settings?

Sorry for being rude.

Best Regards

Yes it does. The local test does use default playback settings (not any profile).

1 Like
twitch instagram twitter facebook