My server is shutting down after 20 minutes

Before we go any further I would like to let you know that I have searched threads for the past two days and I still have not found a solution or a solid reason why I cannot fix my server.

So I’m able to host my Teamspeak server without any problems for the most part. Everything appears to work fine but then comes the annoying part. Every now and then from 20 minutes to an hour, the server just decides to shut itself off. It just says that the server is stopped. And like many other people, I have a problem with licensing.

2021-07-15 02:38:55.203334|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.6 (2021-06-09 10:22:37)
2021-07-15 02:38:55.204331|INFO |ServerLibPriv | |SystemInformation: Windows 10 (19042) x64 (AMD or Intel) Binary: 64bit
2021-07-15 02:38:55.204331|INFO |ServerLibPriv | |Using hardware aes
2021-07-15 02:38:55.206327|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2021-07-15 02:38:55.206327|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2021-07-15 02:38:55.207323|INFO |DatabaseQuery | |checking database integrity (may take a while)
2021-07-15 02:38:55.249212|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2021-07-15 02:38:55.252203|INFO |Accounting | |Licensing Information
2021-07-15 02:38:55.252203|INFO |Accounting | |licensed to : Anonymous
2021-07-15 02:38:55.252203|INFO |Accounting | |type : No License
2021-07-15 02:38:55.252203|INFO |Accounting | |starting date : Thu Oct 1 00:00:00 2020
2021-07-15 02:38:55.252203|INFO |Accounting | |ending date : Tue Nov 1 00:00:00 2022
2021-07-15 02:38:55.252203|INFO |Accounting | |max virtualservers: 1
2021-07-15 02:38:55.252203|INFO |Accounting | |max slots : 32
2021-07-15 02:38:56.103942|INFO | | |Puzzle precompute time: 840
2021-07-15 02:38:56.104939|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
2021-07-15 02:38:56.132866|INFO |Query | |Using a query thread pool size of 2
2021-07-15 02:38:56.175752|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
2021-07-15 02:38:56.175752|INFO |Query | |listening for ssh query on 0.0.0.0:10022, [::]:10022
2021-07-15 02:38:56.176749|INFO |Query | |listening for http query on 0.0.0.0:10080, [::]:10080
2021-07-15 02:38:56.176749|INFO |CIDRManager | |updated query_ip_allowlist ips: 127.0.0.1/32, ::1/128,

Now I would like to point out that I did not purchase any license and as far as I know, the basic server package comes with the free license and as you can see, the license is not expired if there is any?

Important information:
-Teamspeak server Windows 64-bit 3.13.6
-Free license
-License isn’t expired
-Server randomly shuts itself off

Thank you for any help you can provide!

Why do you think you got a problem with licensing?
You would get any error about accounting or slots etc. But you got none.

Something else is stopping the server. Nothing is wrong in log 0 . You may check log 1.

You may try enable ServerQuery logging with start parameter logquerycommands=1 and enable all logging on the server itself. Then check if any ServerQuery / Bot or Tool does this.


Renamed the thread. Title has nothing to do with topic.

1 Like

Hi, thanks for the response. I checked log 0 and here is what it says:

2021-07-15 02:38:56.173756|INFO |VirtualServerBase|1 |listening on 0.0.0.0:9987, [::]:9987
2021-07-15 03:00:18.416259|INFO |PktHandler |1 |Cleaning up connection because of 12 resends of COMMAND packet
2021-07-15 03:00:18.416259|INFO |PktHandler |1 |Dropping client 6 because of resend timeout
2021-07-15 03:07:02.761387|INFO |VirtualServerBase|1 |stopped

As far as I know, it looks fine? Also, I assumed it had something to do with licensing because the “licensekey.dat” file could not be opened.

Next,

I’m not exactly sure how to do this. What and where is the start parameter? I tried enabling all log types through the server itself but I didn’t see any change in Log 0.
image_2021-07-16_125706

I will show my latest Log 0 and Log 1:

Log 0:
2021-07-16 19:54:33.360360|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.6 (2021-06-09 10:22:37)
2021-07-16 19:54:33.361331|INFO |ServerLibPriv | |SystemInformation: Windows 10 (19042) x64 (AMD or Intel) Binary: 64bit
2021-07-16 19:54:33.361331|INFO |ServerLibPriv | |Using hardware aes
2021-07-16 19:54:33.363345|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2021-07-16 19:54:33.363345|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2021-07-16 19:54:33.364323|INFO |DatabaseQuery | |checking database integrity (may take a while)
2021-07-16 19:54:33.402221|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2021-07-16 19:54:33.403217|INFO |Accounting | |Licensing Information
2021-07-16 19:54:33.403217|INFO |Accounting | |licensed to : Anonymous
2021-07-16 19:54:33.403217|INFO |Accounting | |type : No License
2021-07-16 19:54:33.403217|INFO |Accounting | |starting date : Thu Oct 1 00:00:00 2020
2021-07-16 19:54:33.403217|INFO |Accounting | |ending date : Tue Nov 1 00:00:00 2022
2021-07-16 19:54:33.403217|INFO |Accounting | |max virtualservers: 1
2021-07-16 19:54:33.403217|INFO |Accounting | |max slots : 32
2021-07-16 19:54:34.177144|INFO | | |Puzzle precompute time: 763
2021-07-16 19:54:34.179130|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
2021-07-16 19:54:34.189110|INFO |Query | |Using a query thread pool size of 2
2021-07-16 19:54:34.231007|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
2021-07-16 19:54:34.232006|INFO |Query | |listening for ssh query on 0.0.0.0:10022, [::]:10022
2021-07-16 19:54:34.232006|INFO |Query | |listening for http query on 0.0.0.0:10080, [::]:10080
2021-07-16 19:54:34.233001|INFO |CIDRManager | |updated query_ip_allowlist ips: 127.0.0.1/32, ::1/128,

Log 1:

2021-07-16 19:54:34.230009|INFO |VirtualServerBase|1 |listening on 0.0.0.0:9987, [::]:9987
2021-07-16 19:54:36.269618|INFO |VirtualServerBase|1 |client connected ‘Nick’(id:3) using a myTeamSpeak ID from 127.0.0.1:50184
2021-07-16 19:58:18.961068|INFO |VirtualServerBase|1 |client disconnected ‘Nick’(id:3) reason ‘reasonmsg=leaving’
2021-07-16 19:59:09.837849|INFO |VirtualServerBase|1 |stopped

So log shows nothing. Soooooo…

Could be that something on your system does stop the process? Check if the process is still running.

1 Like

The Teamspeak server background process is running when I turn it on and it closes when the server stops. Could it be my malware detection software? I’m running Malwarebytes but it never alerts me of any issues so that might not be it. I really don’t know what could be shutting it down. The only software I run constantly when my computer is on is Discord, Medal, Spotify and Steam.

Also one last weird thing. I must’ve forgotten to shut down the Teamspeak server last night after playing Arma 3 with some friends (yes the TS server still closes every now and then but I quickly start it up again). This morning I come to the computer and notice the server file has these two files in it that I only see while the server is running. I check task manager and there is no instance of the TS3 server but I can see it in the application tray. image

So for the first time the server ran for multiple hours but I don’t know if I was able to connect or not because my stupid brain just double-clicked the TS3 server start-up which replaced the earlier instance.

I will continue to test and try to replicate the conditions the TS3 server had that managed to keep it apparently keep it going.

twitch instagram twitter facebook