My Teamspeak Login Issue

My computer seems to be blocking myteamspeak. I have scoured the internet, Reddit, and the official forums and cant seem to find any info.

When I got to tools and options on teamspeak 3 this is when pops up:

I have no interest in using My-Teamspeak but I figured why not try it to attempt to fix the issue of this annoying popup. When i click “do not show again”… it does show again, so I am forced to see this prompt every time I go to the settings.

I can login to https://www.myteamspeak.com with no issues.

The following quote is what shows when I open teamspeak 3. (Notice the warning)

Blockquote 5/18/20 06:00:57 Info TeamSpeak Client 3.5.3 (2020-05-06 09:07:50)
5/18/20 06:00:57 Info SystemInformation: Windows 10 (18362) x64 (AMD or Intel) Binary: 64bit
5/18/20 06:00:57 Info Using hardware aes
5/18/20 06:00:57 Direct Sound Debug setting timer resolution to 1ms -
5/18/20 06:00:58 ClientUI Info OpenGL Info: LibGLES, Vendor: Google Inc., Renderer: ANGLE (NVIDIA GeForce GTX 950 Direct3D11 vs_5_0 ps_5_0), Version: OpenGL ES 2.0 (ANGLE 2.1.0.57ea533f79a7)
5/18/20 06:00:58 Info *** Time [ICONMANGER]: 180
5/18/20 06:00:58 Addons Info Checking for addon updates…
5/18/20 06:00:58 Windows Audio Session Devel DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList
5/18/20 06:00:58 Windows Audio Session Devel DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList
5/18/20 06:00:58 ProtobufRPC Warning Server at URL https://clientapi.myteamspeak.com/addon responded: 403 Forbidden
5/18/20 06:00:58 Info failed to load static integration list
5/18/20 06:00:58 Info *** Time [BUILD_GUI]: 599
5/18/20 06:00:58 Info *** Time [SERVERVIEW]: 632
5/18/20 06:00:59 Info *** Time [SERVERVIEWMANAGER]: 650
5/18/20 06:00:59 Info *** Time [MAINWINDOW]: 1137
5/18/20 06:00:59 Info *** Time [INIT]: 1137
5/18/20 06:00:59 ClientUI Info Qt version: 5.12.3
5/18/20 06:00:59 ClientUI Info Using configuration location: C:\Users\Davis\AppData\Roaming\TS3Client\settings.db
5/18/20 06:00:59 ClientUI Info Last update check was: Mon May 18 00:37:31 2020
5/18/20 06:00:59 Info Statistics report: Not yet, next report on Sat Jun 6 00:41:29 2020
5/18/20 06:00:59 Bookmarks Info Collecting autoconnect bookmarks
5/18/20 06:01:00 Newsticker Info Newsticker next check: Tue May 19 05:37:25 2020 GMT

I have tried disabling firewall and windows defender and it doesn’t do anything. I have tried 3.5.3 and 3.5.2 and both don’t work.

I acquired the beta install of ts5 and tried to login on there but it would not login. I click login and nothing happens.

Something is not allowing myteamspeak to communicate.

For some reason Cloudflare thinks that your IP is suspicious

In client you get that links because our client can not show them. Have you tried to solve such Captcha?

The login on the website or this forum are not using same URL and may work fine.

1 Like

Hi Chris,

Thanks for your assistance. I have tried to solve the captcha but it does not work…

The first link does do anything:

2nd link I have to press the retry button and then try the solve but once I solve it, it does nothing:

Resetting my modem would assign me a new IP. Might that work???

Resetting my modem worked for now. Not sure why the IP was flagged though.

twitch instagram twitter facebook