MyTeamspeak ID not validate Bug

Since yesterday, when I connect to a server I have this error message

Also I lost all my identities and my servers synchronized (so i lost all my ranks on each servs)

I tried to disconnect / reconnect, I changed my password and I also tried to go to a public server like this one

but nothing has changed I still have the same problem.
What could I do to fix it?

What you describe is not a bug.

You can’t reach our services (check your client log) or you did reset your password and did not enter a recovery key.
You are logged in but the service for sync mytsid etc can not be reached or is not started.

2 Likes

I found my recovery key and now everything works!

Thank you for your answer!
This ticket can be closed

Edit after your post: Gratz :smiley:

We can not restore the key. You are the only person in the world who should have it.

Without the key you need to start from scratch via Fallback or Have a client where your data is still cached when you do a fallback on that Client.

2 Likes
twitch instagram twitter facebook