myTeamspeak Login won't work

Hi tigether,
today my wife encountered an issue. She always received the message, that teamspeak can’t sync the account etc. So we tried to logg her out and in again on TS3 Client. Now its not possible to Log her in anymore. Tried the same on my Teamspeak 3 Client. Same issue. Now we dont have any identity etc anymore. Login on Websites of myteamspeak etc works. What happened?

Hope someone can help pls.

Greetings Caaruzo

You can not log in into your Account right?
Are you 100% sure the mail address and the password are exactly the same as used on the a website?

If you cant sync, then make sure Synchronization is enabled.

1 Like

it is enabled. and yes its definitly the same. Tried with the one of my wife and my one.

Can you post your Client log? :slight_smile:

Well it seem to be working now. Didnt made anything different like i did 2hours ago. Using same accounts. really weird. Btw this happened on 2 different computers ofc.

Ok glad that your Problem is solved. :slight_smile:

I have been having this same issue for the past few days. TS3 client log below
8/21/2020 14:46:29 Info Failed to download remote image: Host s22.postimg.org not found 3
8/21/2020 14:46:29 ClientUI Info Connect status: Establishing connection
8/21/2020 14:46:29 ClientUI Info Connect status: Connection established
8/21/2020 14:46:53 Info tried to request user integration info without valid session
8/21/2020 14:47:19 ProtobufRPC Warning Error contacting URL https://clientapi.myteamspeak.com/authentication: CANCELED
8/21/2020 14:47:19 ClientUI Warning Account login failed, server currently not available. Retry in few minutes.
8/21/2020 14:47:19 SCHandler Info try to delete mytsid while no valid mytsid is set - abort

Have you tried another machine?
Does this website work https://www.myteamspeak.com/ and can you login there?
Have you tried deactivating your firewall?

twitch instagram twitter facebook