Need help with channel subscriptions

I set my server up with the following guest permission:
i_channel_subscribe_power = -1

So everytime a temporary channel is created, guests can’t see who’s in there. My problem now is that everytime someone creates a channel, all other guests hear a “insufficient permissions” with the following message:
insufficient client permissions (failed on i_channel_needed_subscribe_power)

The teamspeak server also has a similiar configuration (you cant see who is in which channel) but the problem doesn’t exist there. Does anyone know how the public server might be configured?

How can I prevent this from happening?

Have you set the i_client_max_channel_subscriptions to -1?


If I change it to 0, the “insufficient permissions” sound and chat notification still occurs, but it fails on i_client_max_channel_subscriptions

i_client_max_channel_subscriptions to -1 ist not workt! :sweat:

just try i_client_max_channel_subscriptions 1000 that should go. :grin:


I don’t understand. What does this have to do with the problem?

do not give your groups -1 but the right 1000 so that the group / user can subscribe to 1000 channels and your problem is gone :face_with_monocle:

No, it isn’t. Because I don’t want to fix the problem by giving guests all permissions to see who is in other channels. Besides, setting “i_client_max_channel_subscriptions” to -1 works perfectly fine.

Here is the solution, user / group (don’t see in the channel but join in)

That is the same configuration as mine. Can you join your server with a guest identity and create a temp channel as the admin? Do you hear “insufficient permissions”? What server version do you use?

Or even better: Can you give me your server address so I could check it myself?

You’re right, if I also create such a channel with the settings, I also get this error message (… needed_subscribe_power) hmmm :thinking:

I think there is a Teamspeak Bug xD
@florian2833z yes of course: Ts: (no advertising)

This is my Guest Config

its works perfect. :slight_smile:

Oh hell no …
But how does the public teamspeak server manage not to send that to all guests all the time ? Weird.
Maybe @TS.ChrisR can help us out.

Seems to me like your guests can see all channels … If that’s true, then this is not what we’re trying to solve here.

No, since I have a public teamspeak, I of course changed it again.