Notification Issue

In Beta59 and some previous versions notifications seem to be a bit lazy.

Most times pokes won’t popup nor open a chat tab in servers section, the same happens with private chats. Private chats seem to trigger all missed notifications, most times hours later.

In general I’m connected to 4 servers at once and need to recieve notifications in time from all of them. All notifications, except some warnings, are enabled or allowed to ignore afk.

1 Like

As there was no fix in the current version and hotfixes I tried to reproduce my error and succeeded easily.
I simply poked myself with TS3 and it worked the first time as it shows this little popup in the server tree, but still doesn’t open a chat in server tab section, chat opened as is started a private chat.

Afterwards I switched to another server which I was already connected to and made a second attempt. This time none of my 7 pokes showed up in any way. Just like the first time I opened a private chat and expected to finally see something in server tab section.
Something happend indeed, but it was the chat from my first attempt on another server and another id that popped up in server tab section.
I was simply not able to let any other chat appear in server tab section then the one from my first attempt.

It seems kinda broken to me and really a bit odd, hope there’ll be a fix for this issue.

1 Like

So far this is nothing we have or had on our radar yet.

Are you the only who experienced that notifications (pokes , messages etc.) open late?
Do you have more details about the situation or an way to reproduce this?

Same counts for the issue that wrong chat opens on poke.
For us the server chat to the user is used when sending or replying or getting a poke.

3 Likes

Tough question as I’m the only active user of TS5 in my guild so far.
Yesterday I got all of my test pokes some hours later, guess they were trigged by channel chat this time. Funny thing: they all showed up indiviually with a little time in between.

I simply open another TS client, in this case TS3 and poke my TS5 identity. The first pokes seems to update the notification bell as there appears a notification, but no chat tab opens nor the poke itself in the servertree.
If I’m not much mistaken opening a private chat shoul open a chat tab aswell, this also seems not to work like expected in my client atm. Actually opening a private chat triggered a chat tab for a poke I sent myself earlier on another server and another id but no tab for the actual chat I just started.

I’m quite sure this worked with no problems some time ago. I started using TS5 in early 2020 and never had any problems.

Edit: I’m not able to reproduce this issue on another device, maybe a year and a half of patches in my current client broke something. I’ll try with a fresh install and return afterwards for a response if there’s still an issue.

1 Like

Simply un- and reinstalling didn’t fixed the issue. Afterwards I made another attempt and wiped all directories aswell. The one in “AppData/Local” was close to 500MB in size.
After another fresh install the issue seems to be solved for now as I cannot reproduce the issue any longer.

Maybe this issue is based on large log files or sth. similar. The client worked fine for a long time, so this might be not easy to reproduce unless you use the client on a daily basis for over a year.

Even if everything works as it should for now I’m really curious why this happend at all.

1 Like

Logs should not be any problem.

Could be that there was a bug in an older version that got triggered somehow but as long we can not reproduce this we can’t find out what happened.

ps. to make a clean install you need to wipe the TeamSpeak roaming folder.

4 Likes

I’m having the same issue. It started happening a couple of updates back.
Notifications appear delayed (in some cases very delayed) 8/10 times.

If someone has poked me and I didn’t receive the notification, it seems like that notification is shown if someone other sends me a message - but I still won’t get the last person’s message.

If someone messages me, TeamSpeak will sometimes give the notification sound, but the message won’t show up anywhere. I have to manually open the chat with that person to see the message.

2 Likes

Yesterday we had another report and he could solve this (the hard way).
Not the best way but we haven’t found any how to or could reproduce it yet:

  • Make sure you know your myTS login data.
  • Close the client
  • Open %AppData%\TeamSpeak\Default on Windows
  • Rename the settings.db file
  • Start the client and login to your account
3 Likes
twitch instagram twitter facebook