Oddness when connecting

Hi,
I have looked through the forums but could not find any mention of something similar happening…

I own a hosted TeamSpeak server which I hadn’t had need of for a few months. Recently, I have decided to use it again. Yesterday, when we try to use it, my “guests” were not able to connect to the server. Because oddly I was still connected, I decided to change the password on the server’s interface, but when I tried to log in again [using the old password], I was not kicked out or asked for the correct password but simply was allowed in.

After setting the password to something new twice more, my guests finally were able to connect.

However, today I tried to connect to my own server, without any password in the TeamSpeak interface – I was still allowed in. Right now, I have set the password to “invalid” in the Manage Favorites interface – which of course is as far away from the real password as it can be – but I am still allowed in. Even if I just try to open a connection by typing the URL and an invalid password after Control-S, I am admitted. Is there some technology like a cookie that lets the server recognize the client – in this case mine –, maybe even as admin?

Hello this is quite normal if you are Serverdmin with permission b_virtualserver_join_ignore_password that you can login without the password

Thank you, that is good to know - though it begs the question: how does the server recognize me, only by the username?
I will have to check how to disable ignoring the password, because without that setting I probably would have noticed a typo in the password earlier.

hello no he recognizes you because of your global identity

Thank you, so it’s a cookie-like mechabism - a piece of datra o the computer that identified me. Now I have to contact the hoster how to turnm the setting on and/or off…
It is a relief that it’s not a “simple” cookie, tramsferred in clear text :wink:

Your global identity is on your client not on the server

Tools ► Identitiers (TS3)

twitch instagram twitter facebook