Output Device Doesn't Change

I have the most recent version of TS3 client installed on Win 10 Pro 20H2, using with a HyperX Cloud 2 headset. TS picks up the audio from the microphone without issue, however, no matter what I change my output device to, the output is coming through my Oculus Rift. Even when I DISABLE the Oculus output devices, the software continues to try and access that device. I’ve changed the defaults in Windows, I’ve changed the device in TS3, to no avail. Does ANYONE have any suggestions on how to fix this?!

You must change your default Communication devices in Windows.
These are the devices the client will use when no other device is forced in your client settings.

1 Like

Chris, you failed to fully read my post. I did change the default communications device. i’ve changed ALL of my audio devices to be my headset, but Teamspeak refuses to acknowledge the change. It ALWAYS sends the audio through the Rift. I just uninstalled my Oculus Rift, and the audio REFUSES TO PLAY THROUGH ANYTHING. Period. I’ve changed ALL of my audio settings to be my headset, even to the point of forcing Windows to put the audio from TS3 through my headset, and I still hear NOTHING.

I did read all of your post but it gave not the details i answered you.

You did not write any of that.

Are you sure you did that?
There is a difference of changing the device or changing the default communication device.

And what happens when you select the headset directly in the client? have you tried that?

1 Like

Here is the quote from my original post. It clearly says I changed the defaults in Windows, but that’s besides the point.

I did select the headset directly in the client. No matter what I select, the audio does not come through anything but the Oculus Rift. Because of some other issues that creeped up, I did a refresh installation of Windows this morning. I will re-attempt TeamSpeak3 when I get home and I will update if I continue to have issues.

twitch instagram twitter facebook