Password Immunity Channel Group Permission

It has been months since this started happening in TS3 Client. Basically, the password immunity/ignore permission for channel groups still brings up a dialog box for users trying to connect the channel and asks them to enter a password. They can enter even if they leave it blank but thats not the whole point of the permission. It used to be simple before. People with this permission could connect without the “Enter Password” prompt popping up.

Moreover, the permission works as intended for server groups. The prompt only pops up for channel group permission (which is b_channel_join_ignore_password)

1 Like

The difference between the server group and channel group is simple.
Server group --> whole server
Channel group --> specific channel(s)

So how it works, if you have the “ignore passwords” in a server group the server automatically doesn’t ask for a password. If you have it in a channel group (let’s say channel admin) then if you are inside a channel where you are guest then the server will ask you once for a password, but if you are already a channel admin and trying to access a locked channel where you have the same channel group (channel admin) or a channel group with the “ignore passwords” permission then it won’t ask you to enter it as it reads you already have that permission enabled.

As you said, an empty password does the same thing and let you in. If you don’t want to have the password dialog all the time a very simple solution is to go under Tools --> Options --> Security --> Check “Save Channel Passwords”.

1 Like

But this issue has already been fixed in TS5 Beta. I’ve already tried it there and it works fine. Many users in our TS3 Server complain about channel admins not having password immunity just because they don’t know how this permission works and never try joining the channel by leaving the password box empty. It is just another complication for the staff members to explain to each and every new user about how the password immunity works. We can’t just ask everyone to enable the “Save Channel Passwords” option.

The solution to your problem then, is to set the welcome message or the host message explaining it.
Or use a bot to send a message when they join the server.

Honestly, i don’t think that you will find at the moment another solution.