Please Fix the Following ts5 issues

1 App will crash and go blank and come back but nothing in screen expect a gray screen only way to fix it is close whole program an restart

2 ptt still not working properly while in other programs like task manager and i also found out while installing MYSQL installer also happens on ts3 no issues like this happen

max memory useage is 7gb power useage is very high

also it seems i have 6 ts5 clients running on on task manager and one listing as teamspeak as drop down list shows


fix the ptt as seems i notice a delay also sending message is delaying or you can send multiple message of the sae within seconds by hitting spamming send button as a server admin


:thinking: :thinking: :thinking: :thinking: :thinking: :thinking: :thinking: :thinking: :thinking:

restarted client after 3 days useage


Is ur client updated to the latest version?
What is ur operating system?
Do u have all windows updates installed on ur operating system?


yes below
Build Date:
20/12/2019, 10:34:03
Chromium Version:
win10 pro
yes all updated tooo


You can right click anywhere inside TS and the black areas should disappear. This doesn´t work all the time but if you don´t want to restart the client for whatever reason you can right click and the first time a black area goes away just move around with your mouse and the rest should go away too.


no the whole thing crashes and cant ricght click and also noticed the X screen minimise button disappears too so its one big gray /black screen no windows or borders


any admins able to help me on this issue ive spoken with supporttoo but they dont understand me
@TS.ChrisR @TS_Chris


The “Power usage” appears to be just an arbitrary thing Microsoft made up somehow for some reason. It doesn’t seem to mean anything, other than maybe “this appears to be a very active process”. At least that’s my understanding of it. I have processes that have been idle not using any CPU and a mere 30 MB of RAM for the past 6 hours, yet they are still displayed as “Very high”, presumably because they used like 10 gigs of RAM and 20% CPU for a few hours before.

As for the memory usage: If you’re seeing a lot of animated images or a very large one (dimension / file size wise), then more resource consumption (both CPU / Memory) is expected.

As for the 7 processes, they all belong to the one instance of the TeamSpeak client you have open. TS5 is multi process, so 7 processes is exactly what is expected from a properly working TS5 client at the time of writing.

Blacking out of some areas is a known issue that needs fixing, as far as I know we haven’t determined the cause for that yet. If the right click in center area trick mentioned above doesn’t work you can usually still click where the buttons used to be and it will respond to the click. So just clicking the top right corner (where the X usually is) will usually still close the client just fine.

Hotkeys don’t work when your current focus window is running elevated (such as Task manager). This is a Windows security thing, not letting other applications know about keys being pressed if the focused application you press the keys in runs in a higher elevation level than your own process. We’re looking in to possible solutions for this, but it doesn’t have the highest priority.


i think it may be due to chrome crashing or somthing simmilar /freezing up

also with the processes its been running for at least 3 to 5 days thats why high ram and cpu i believe


also any thing about the ptt while on task manager or other similar programs not working works fine on ts3 but ts5 ptt does not activate while on taskmanager or installing program

1 Like

hello only fix to the hot keys thank you for mentioning admin and higher elevation running ts5 as Admin you need to run ts5 as administrator and the PTT keys work @TS_Chris

1 Like

Fixed But warning if you run as administrator this is at your own risk


image with ts as normal user cant use ptt

picture with run as admin perm on

do this here add the tick box to the teamspeak program


Running TeamSpeak or any software that doesn’t explicitly require elevated privileges to do it’s work like this is a bad idea.

The way I understand it, any security vulnerability found within the software may have a lot worse consequences when run with elevated privileges.

Why would anyone want to do this, just because key bindings won’t work while task manager is open?

The most obvious solution is to not have task managemer running all the time.

Seriously. Didn’t anybody think about the implications?


It doesn’t even matter if it is running.
The only time the hotkeys don’t work (because our application is never informed about keys having been pressed by the OS) is when the active window that has the focus is of a process running with higher privileges than our process.


This makes it even less of an issue, unlike a game is running with elevated privileges, or am I missing something here?

I just can’t think of a realistic use case where this problem is a real show stopper which justifies “fixing” it with “run as administrator”.

And I think “fixes” like this should not be spread without “caution” signs all over them. Most people won’t know what they are doing.

1 Like

i am aware but it resolves some of the software i run within windows and yes i know what im doing and i know the risks i do monitor the network as well as blocking sites please note that was an example program i was describing what i was seeing with keys not responding

i have made it clear run at your own risk

1 Like

1576838043 is not the latest version…

1 Like

Thank you. :+1:

1 Like

yes im aware just tested on latest version still exisits but as stated run at your own risk im happy to state this post resolved but please @TS_Chris please maybe have a warning if running as administrator may harm or distroy your system run at your own risk

1 Like