Plugin api version is 2 while 3 is required

What do i need to do, since today my teamspeak server is not working anymore.

This is my log, i dont understand.

2021-02-01 15:19:27.327108|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.2 (2020-11-18 11:37:32)
2021-02-01 15:19:27.342733|INFO |ServerLibPriv | |SystemInformation: Windows Server 2016 (17763) x64 (AMD or Intel) Binary: 64bit
2021-02-01 15:19:27.342733|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2021-02-01 15:19:27.342733|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2021-02-01 15:19:27.342733|CRITICAL|DatabaseQuery | |Plugin api version is 2 while 3 is required

No i do not run any plugins on my teamspeak. Only client sided but the server just does not want to start!

update to 3.12.3 (latest)

I did, but then i need to completly remake my teamspeak

no, you don’t.

Follow these steps:
1. Stop your old server instance (Do not kill it! Or else you will not be able to start your new server for the next 2-3 hours!)
These are official supported ways. to shutdown the whole server.
All ways will shutdown the whole instance and will report, that slots are not used anymore.

All operation systems:
The ServerQuery command serverprocessstop.
click me to get an "how to use the Query Interface with Putty"

Right-click into the Server Tray Icon -> Then press Exit

Linux/FreeBSD shell:
The command ./ stop if your server was started with ./ start

2. Make a copy of the existing ts3server.sqlitedb to have a backup in case something bad happens.
*Make a backup of your TS database in MariaDB/MySQL in case you do not use SQLite

3. Download the right server package from

4. Extract the server package

5. Overwrite the server files and folders with the extracted content. Then paste the ts3server.sqlitedb file

6. On Windows/Mac OS start the ts3server binary.
On Linux/FreeBSD start the server with the
(First start can take some time)

Just found the related post:

When I have done that it just doesn’t start. It gives me the plugin api error in my logs

it doesn’t start even after the upgrade?

Oh wait, something worked! :smiley: Let me check hold on!

Fixed it! Thanks for your help man amazing!

You’re welcome man, I had the same problem this morning

1 Like

I am getting the same thing, and tried all of this but I did shut the server down before I read this, it will not start, and i get this log file, what do i do now?
2021-02-09 13:27:54.385172|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.3 (2020-12-16 14:17:05)
2021-02-09 13:27:54.386170|INFO |ServerLibPriv | |SystemInformation: Windows Server 2012 R2 (9600) x64 (AMD or Intel) Binary: 64bit
2021-02-09 13:27:54.386170|INFO |ServerLibPriv | |Using hardware aes
2021-02-09 13:27:54.387132|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2021-02-09 13:27:54.387132|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2021-02-09 13:27:54.387132|CRITICAL|DatabaseQuery | |Plugin api version is 2 while 3 is required

twitch instagram twitter facebook