Problem with Automated Gain Control (AGC)

Hello everyone,

the automatic volume adjustment of Teamspeak (AGC) causes that whenever I stop speaking the gain is increased and you hear static noise for a short period of time. As soon as the automatic volume adjustment is deactivated, there is no noise anymore. If I directly record the microphone or use another application like Discord there is also no static noise at all.

Since the latest Teamspeak version the option has unfortunately moved to the playback settings, so I cannot influence the AGC for my own signal anymore.

Do any of you have an idea how to solve this problem?

Example of the Problem (1. TS with AGC, 2. Direct Output from Microphone): Teamspeak Ton Problem - YouTube

Microphone: Rode PodMic
Interface: Focusrite Scarlett Solo (3rd Gen)

1 Like

Additional Information:

Gain at the Scarlett is set to around 80%.

Settings in Teamspeak:

Windows Settings:


I get what you report but the thing is there is no AGC Feature any longer for input (Microphone, stereo Mix etc.). This is why there is no setting under the capture tab.

What could be is that your device is sending really low at the end and the playback part things that it needs to raise the volume.

Also raising the volume could cause the noise you hear.
You may lower the volume of the microphone below 100. From my experience something around 50 is enough. Everything above caused distortions.

Short summary.

  • Capture has no AGC in TeamSpeak.
    The only way to have a AGC similar feature on input is the signal that was send from the device/driver to the client. TeamSpeak does not touch this or has any control over it.

  • Only Playback (what you hear when other talk to you) has the AGC feature.

  • When you do a local test then you will always hear the result as AGC playback was enabled.


A post was split to a new topic: Is AGC enabled for Whispers?

I’m using Teamspeak since a lot of years now and I always liked Teamspeak more than Discord, Mumble etc. But I’m facing a lot of issues with AGC. I downgraded the Version a while ago but today I decided to Update again and check if it’s better now. And no it is not.
In my opinion it should be removed completely. It is way to aggressive on the gain.
The issue is when I’m speaking normal or more quiet it is increasing my gain very much. When I’m in a round of CS:GO or something else and I start screaming “RUSH B” all my friends are hearing loss.

This is not working as it should be and will never. I think there are two options for improving it.
Either remove it or add a procedure where it mesures the “normal” Audio gain and stays at that gain.
When I’m whispering I don’t want to be that loud as Teamspeak is regulating.

Which version you are using and which one used by your friends?
There’s really nothing wrong with the AGC.
There is usually a problem with this when using versions 3.3.x and 3.5.x.
As the AGC was varied with 3.5.0
I suggest upgrading the whole team to a version above 3.5.0 (preferably the latest :D) and the problem disappears.

own experience :slight_smile:

We are all using 3.5.6
I can definitely reproduce that when testing the microphone in Teamspeak that when I whisper that TS is increasing the gain way to much. It does also do it when I’m typing on my Keyboard. So everyone can hear my Keyboard extremly loud just because Teamspeak is increasing the gain.

The problem is not AGC in the client. There is no active Code for AGC on Capture.


But why is the Volume increasing so much? It is only in Teamspeak. I’ve Voicemeeter installed and when I listen to my microphone which is set to 60 everything is perfect. When I listen to the Test function of Teamspeak the Volume is getting higher and lower depending on how I’m talking or if I’m typing on my Keyboard or not. When I’m not talking you can hear the Volume increasing so much that you can hear my Computer fans.

I wrote why it is in local


My Friends are also saying that they can hear that. I think that issue is worse when using a condenser microphone

I’m using TS for a RedM roleplay server and I have a major issue. It seems that in version 3.2.5 this issues does not exist and I am able to disable “Automatic voice gain leveling” in the settings. However when I try to disable it in any of the new versions of 3.5, checking and unchecking this option does nothing. This is a big issue, it picks up almost all background noise and any static. I hope this is solved soon.



the newest version is 3.5.6 and there is no problem with agc :smiley:
just you and your team need to use similar version.
(exemple if you use 3.5.6 they need to user minimum 3.5.0.)
there is a big difference between 3.3.x and 3.5.x .
i recommened to use the newest version.


Well I also have problems with AGC still being active in 3.5.6 for me and others. First thing first yes I have AGC turned off in output options. But a friend of mine still was changing volume all over the place. And after I told him to turn off all windows and TeamSpeak settings that could change his audio level, he still had the problem. So even if he had an older version of TS AGC would be turned off. And while testing my mic volume in the TS setting I had the exact same problem. So just to be sure I downgrade to 3.3.2, so I can turn it off.

merged by moderator

My mic is normal on every app except TS3, mine is on version 3.5.6 , I tried to download the 3.3.2 version it works if i disable the AGC, but i can’t install the salty chat in it, My friends tell me that my mic is earraping them, but when I check on discord or windows audio, it is completely normal, it only happens on TS3 Version 3.5.6. If u have any solution pls help me cuz i can’t play roleplay correctly.

Your microphone seems to be quiet and the AGC from other clients input tries to fix this.
You may check and play around with your audio input in your operation system or driver.

It’s not the client raising the volume of your microphone.
In 3.3.2 this was possible when AGC was part of it. Explained in post #3 in this thread.

1 Like

it is not quiet, I it is in fact quite loud, the AGC made my mic very-very loud, inhumane - ly loud, this only works on ts3 idk why.

merged by moderator

When i use usb-microphones in newer ts versions, my mic gains som much when i am not talking.
Could this be fixed?
I cannot use the newer TS-versions because this occurs. really annoying.
The issue is that the mic suddenly starts to “look” for sound. So when i am silent the mic gains to the heaven, automaticly, so the mic sound itself gets much higher.

I dont have this problem on 3.3.0 version of TS. But the problem occurs on the newest version, 3.5.6.

I have acess to the beta-client, but i use overwolf, and that doesent support ts Beta atm. And the beta dont have keybinds for changing channels quickly, wich i need.

Why move my thread here, when it is no fix here?
Yoou guys says that its not the client version that causes it?
I find it hard to believe that.
When i downgrade to 3.3.2, i have no issues at all. But then i loose the automatic voice levelling option, and i find it REALLY annoying to set the voice volume of all the members, all the time.
You should fix it back to how it was before.

It has ot be client wise. Or you guys from Teamspeak have to try harder to solve this.
If noone answers me here, ill just make a new thread until i get a answer.
I dont get ANY fix from this thread.

That what happens in local, also happens in the chat server, when i talk to others. I get yelled at, because they find it annoying. If i test this in the Ts client versions before acg was moved, i dont hear the gain in the local test.

How is this possible? I used the newest version, all other member used the newest version. And mu mic gains as hell. I realle need a fix to this!!!