PTT stops working only after I join a game

Hi all,

I recently updated my mouse to a Logitech G502 Hero and installed GHub to control it. I have tried both version 3 and 5 of TS and currently have the ptt assigned to the G4 button and hotkeys to F20 (I have also tried insert, numlock, period, right alt) and it work fine but as soon as I start any game it stops working and does not broadcast. If I change it to voice activation or constant it wors fine.

I’ve been using TS for years without issue and was wondering if its something to do with TS and GHub and if anyone is aware of how to resolve.



Your mouse has probably different profiles for different games and therefore no longer uses the hotkey you specified on G4 when the software recognizes that a game is running on your computer.


Thanks for the reply, I was about to say nah cant be that because its set to the default but thought… Ill go double check. Default means squat :slight_smile: have to set the it for each game. Thanks Leon, There should be a way to set it to Default for all but at least you solved my issue for the most part.

Cheers mate

1 Like