Push to Talk Won't Work

Hello there,
I am new to Team Speak, the server I am in requires push to talk for all functions. At first it worked fine then out of no where it stopped working. I have uninstalled and reinstalled multiple times but nothing has worked.
I am able to set a key for push to talk and it saves it but when I try to use it I get nothing.
It is picking up my microphone because I tested voice activated and constant and teamspeak picked up my voice for both of those.
I am at my wits end and would appreciate any help!!

On which button are you trying to set?

I’ve tried lots of different buttons both on my keyboard and mouse

Check your Hotkey Profile

Another possible cause of the issue can be your hotkey profile. If the wrong hotkey profile is selected in the settings, your microphone will not activate and hence prevent you from communicating with others. Otherwise, you will have to make sure that the correct hotkey is assigned to the push to talk option. Do the following to check your hotkey profile:

  1. To check your hotkey profile, click on the Self option in the menu bar of Teamspeak.
  2. After that, move your cursor to the Hotkey Profile option and make sure that the correct profile is marked.
  3. Alternatively, you can go to the Tools option and then select Options from the drop-down menu.
  4. Afterwards, switch to the Hotkeys tab and make sure that the correct profile is selected.

@mantis_tobogganMD Let me know if you solved the problem.

Hey opZ1ca, it looks like it was selecting the default hotkey profile. I’m not sure how it got switched but somehow it did and was messing it up. Now it should be good.
Thanks a lot!

1 Like
twitch instagram twitter facebook