QueryLogin bug?

Server version 3.12.1 Linux

The story of how I broke the server (DB)
I do everything as usual, creating a separate query user for the bot (queryloginadd), give it the group ID 2 (Admin Server Query).
Everything works as usual, then I decide to change the username query , delete the user’s query (querylogindel), I create anew a new user and after a while I notice that through the client I do not see the query of users in the group.

Since the queryuser is not linked to the server, it cannot be removed from the group without selecting the server, if I select the get server…

since the client is no longer in the database

Only way to fix the database is with your hands.
Is this an error on the server side or did I do something wrong? Yes I know that query groups cannot be type use but I already 10+ years do pissing bots and everything always worked)

It’s important to select the right server first.

You can not delete anything from server 0 when server 1 is selected as an example.

1 Like

I don’t really understand you, but I tried…

So you tried these commands in order?

queryloginadd client_login_name=bot1
cldbid=44 sid=0 client_login_name=bot1 client_login_password=7dGfkJ6g
error id=0 msg=ok

servergroupaddclient sgid=2 cldbid=44
error id=0 msg=ok

servergroupdelclient sgid=2 cldbid=44
error id=0 msg=ok

Worked fine here as you can see.
Are you sure that cldbid=143 is till in ServerQuery?

1 Like

So the cldbid does not exist at all? I do not get why you try to delete something that does not exist?

What is that “143?” thingy asking?


this is the problem, I do not have such a user but it is in the group ID 2

servergroupclientlist sgid=2
error id=0 msg=ok

OK i can reproduce that not existing client is still listed with command.

servergroupclientlist sgid=2

This is a bug but he is gone when i restart the server instance.

Your last picture/Gif shows me that you do something i don’t want to give any support for.
Please fix your server database by starting from Scratch. You should not see any Query groups in a client!

1 Like

everything is good in the database…

Yes database is fine. This is why it is fine after a restart.

But you broke your database by adding yourself permissions to you should not have.
This has nothing to do with reported problem. My support ends here.

1 Like

these rights can not break the database in any way, we used bots that created a query group when each user was connected, and with an online 100 people, we had 450+ temporary query groups, but we stopped using it when it was limited at the server level
how should we test the server and everything else without using query rights? via Telnet? I’m shocked