Recovery Key doesn't work

Hi, i wanted to connect my handy with my TeamspeakAccount. To Connect it the App asks me for a Recovery Key. The one i had didn’t work so i requested a new one but the new ones i get also don’t get accepted don’t know what to do to connect both accounts.

You are asked for the recovery key after you opted to reset your password (ie. on myteamspeak.com).
All synchronized items are encrypted with your account password, before the client sends them off.
When you reset your password, the password does no longer match that with which the items have been encrypted and as such they cannot be decrypted. That’s when you need your recovery key that was provided to you.

If you use the same myTeamSpeak account on both devices, then both will ask for a recovery key.

In TS3 there will be an exclamation mark icon in the bottom center on blue square background (at least in the default iconpack). If that icon is displayed it means that the client cannot decrypt your synchronized items and cannot request a new recovery key. You can double click or right click said icon to have the option to enter your recovery key. If it gets rejected try again a few times.

Please note that when using the new client, you will most likely have received a new recovery key when you first logged in, which is the only valid one for the account from that point on.

If you don’t have your account recovery key, the only other option is to use the fallback mechanism. This will erase all your synchronized items on our systems. The client you’re using the fallback mechanism on will then try to upload its locally cached items if there are any.

You can request a new recovery key in Tools -> Options -> myTeamSpeak -> New Recovery key, however that only works if the client can currently access your data (that is if your account is not in recovery mode, ie. asking for a recovery key to be applied).

2 Likes

This should probably also go into the FAQ if it’s not already in there.

1 Like

A post was merged into an existing topic: I get “Failed to restore recovery key” after entering my key

hello,

So i am having kinda the same problem. i reset my password and i have my recovery key but every time i put it in i get " Failed to restore recovery key" is there something i am doing wrong or what do i need to do bc im lost.

The key you are entering does not match the encrypted data we have stored.

Reasons could be that a new key was requested in the past or account was reset and fallback was used before.
Both make the original key invalid and require to enter the new one.

There is nothing from our side that we can do. The data are encrypted and we have no way to restore them. This is why only you as the user get the recovery key.

1 Like

Hi Chris,
first of all thanks for this very informative post.
I was sent here by Dani after I contacted the Ts³ Support for my problem, in which I can’t use my recovery key after my login hasn’t worked for several times.
After some logins failed I changed my password, and as you say above it asked me again for my recovery key.
Neither my written down recovery key, nor did the new one I got for request of it.

Both the login, same as my old recovery key worked for my Android Ts³ app.
(I didn’t try to use my new recovery key in order to protect the synchronised and logged in account in my app)

I did, for three days now. I really hope you could help me in this case,

thanks a lot and stay healthy,

Luca

What you describe can’t be the case these rules count when it is one myTS account.

  • There is no way you can have any active logged in account when at least one client asks you for the key.
  • There can’t be one old or new Recovery key at the same time. A new one always makes the old one invalid.

Only a password reset (not the same as a change) will force you to enter the recovery key.
When a key was not accepted multiple times then it is just wrong for your account encryption.

What you could do when you still have the data on the android device:

  • Move all items (drag and drop all Bookmarks and identities to the local section) and then do a fallback on the client where you get asked to enter the key.
  • Write down the new key.
  • Login again on the mobile device and move your data back to the synchronized section.
1 Like

My phone was logged in my account since I could see my synchronised favorites and identities.
I today created a new recovery key done at my phone’s logged in account and tried to use it on my pc, with no success.
After I created my new code my phone asked for it, first accepted it, but opened the window for the key again. As I tried again it rejected it.
Now I can’t use the key on my pc neither my phone.
I would wish Teamspeak support to be able to get me a new recovery key that’s working for me, or maybe even check on a support device if the key is working for this one.
Anyway, i please you to be able helping me in this case.
If you wish, I could also enclose some log data, if needed.

Thank you really much for you effords,

Luca K.

The old content is still in a cached mode for the case that your account data needs to be reset via Fallback.

There is no reason to enter any key when the login works as it should! You should not even get asked for it! I’m pretty sure the login on the mobile device is not valid and you just see cache.
Could be a bug that you are able to create a new key there.

Please do as i did describe the post before. There is no way around this to ensure your account encryption working.

We from TeamSpeak can not create you any key or read your data.
Only the person whit a valid key and the login data can do that. And that is the owner of the account.

2 Likes

Both my phone and my PC are asking for the key, both devices are logged in, but none of them is showing me my synchronised Favorites and Identities.

I got three recovery keys that I kept copied, the first I got and tried once my login wasn’t successfull, the one I created after it said my key is wrong, and the one I created on my device that was somehow mb due a bug able to do so.

Every day I try to use those keys on my pc, but with no success.
I still don’t know if my keys are valid at all, or if my client is somehow buggy itself.

I of course tried to uninstall my client and keep the data, to ensure not losing them all, since I now only got some local favorites and my settings left.
Shall I try to copy my data, and reinstall teamspeak again without keeping my data?
Could it be possible that one of the keys is working afterwards?

Thanks,
Luca

This is why i wrote that.

In your case you need to do a Fallback instead of entering the key.

1 Like

Somehow my Android device is showing me my synchronised data, although it is asking me for a key.
Can I move synchronised favorites and identies to my local stuff on my phone?

Because of cached data.

Yes you can as said before. Just drag and drop them to local by holding the the 3 lines icon next to the items…

1 Like
twitch instagram twitter facebook