Run TS Beta 5 as Administrator

How can I manually run Teamspeak5 Client as administrator? I see there is 1 post from Jan 20, but nothing since. The answer in that post was we are looking into it, but not highest priority. This should be a priority as anything run as administrator diables the use of PTT with it making this useless. With TS3 you can atleast right click on it and run as administrator and then it works.

Maybe i missunderstood anything, but why shouldn‘t worki this for TS5 as well?

On Windows 10 is it working for me:

Yea that doesnt show up for me. I installed it using teamspeak-client.msi


As you can see from this, I can set 1 program as run as administrator but not teamspeak. I then tried to find out where that program is…

And here it shows as an application with no directory where it is.

i have tested this on a new Windows Machine and I must say it is working for me too.
What you could try is to re-install the Client and select the following:

  1. Select: “Install for all users on this machine”

  2. In the Next Step, the setup asks where you want to install TeamSpeak Client. (See Screenshot)


If you have the right path selected, then go to the last step and select: "Create a shortcut for TeamSpeak on the Desktop.


So if TeamSpeak was successfully installed, then try to open the Client as Administrator.


I hope this will solve it for you. :slight_smile:


Yup that worked like a champ… Good call… Thanks

1 Like

Glad to hear that is working now.

Welcome to TeamSpeak :blue_heart: