Self-hosted Server, Error investigation: error 1541 invalid parameter size

Hello there, fellow TS users and admins,

I’m hosting a server with NPL license for 8 years now, and this is the first time ever when I encounter this error: https://prnt.sc/t137l0
I am trying to figure out, what the heck may cause it? The only difference I know was made before and after the error has started showing up, that I have created the 10th virtual server my license is allowing me to have. Ever since I have done that, this error is coming up on the YaTQA program as soon as I am trying to log on to any of the virtual servers I am hosting on my VPS. I have googled for the error but the results found were not pointing me in the right direction, so I came to you to get some more skilled admin’s insight and possibly to get roasted as well. :slight_smile: If anyone would be able to tell me what to do, I’d be really thankful! Since the error is not a YaTQA error, I did not go straight to the Dev, instead, I was searching for a solution within the TS community… I hope I wasn’t making a bad call.

Thanks in advance for any useful hints and tips!

What server version is this happening on? Make sure it is 3.12.x.
Have you tried it without YaTQA? (please post the full comand when you try and get the error again)
What happens when you stop/delete the 10th server?

1 Like

I haven’t try that before, but now that I did, there is no error in that method. I guess this is not suggesting any error then… right?

which in the end concluding in a YaTQA error…? When I stop or even delete the 10th server, the issue in YaTQA remains the same. I’ll go ahead and see what happens if I reinstall YaTQA but I guess that probably won’t make a difference either, at least if it is due to a file written somewhere which will have an effect on the new YaTQA install afterwards…
Oh and about the server version: it is up to date, 3.12.1, the newest I can download. (I keep a close eye on the updates all the time.)

There is one more thing which, if you don’t mind, I’d like to ask about. After the latest YaTQA update, this started showing up… do you know by any chance, what is this? :open_mouth: https://prnt.sc/t1ctj9 Is it possible that these are related issues?

I can not help you with the YaQTA part (not our software) but you could start your server with parameter logquerycommands=1 to see what command was send when you tried to select your server there.

1 Like

that logquerycommands=1 is what I can put into the start script, like when the serveradmin password is getting reseted, right?

Yes (in case you mean serveradmin_password=<password>).

Thank you for your time and insight ChrisR, I’ll do a restart during the night when the user count is the lowest again, and will be back on the results of the logquerycommands=1. Thanks again, have a nice day for the time being! :slight_smile:

1 Like

hm… impatience vs me, 1:0
I was like, meh, doing a restart is a second, so why waiting, users will survive. They did, and reconnected. On the other hand, the log files don’t show any errors at all:

cat ts3server_2020-06-17__11_59_58.627391_0.log

2020-06-17 11:59:58.627574|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.12.1 (2020-03-27 10:38:47)
2020-06-17 11:59:58.691841|INFO |ServerLibPriv | |SystemInformation: Linux 5.4.0-33-generic #37-Ubuntu SMP Thu May 21 12:53:59 UTC 2020 x86_64 Binary: 64bit
2020-06-17 11:59:58.691924|INFO |ServerLibPriv | |Using hardware aes
2020-06-17 11:59:58.786752|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2020-06-17 11:59:58.786861|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2020-06-17 11:59:58.787355|INFO |DatabaseQuery | |checking database integrity (may take a while)
2020-06-17 12:00:00.190620|INFO |Accounting | |Licensing Information
2020-06-17 12:00:00.219689|INFO |Accounting | |type : Non-Profit License
2020-06-17 12:00:00.219922|INFO |Accounting | |starting date : Fri Jan 31 00:00:00 2020
2020-06-17 12:00:00.220000|INFO |Accounting | |ending date : Tue Aug 18 00:00:00 2020
2020-06-17 12:00:00.220028|INFO |Accounting | |max virtualservers: 10
2020-06-17 12:00:00.220062|INFO |Accounting | |max slots : 512
2020-06-17 12:00:01.638583|INFO | | |Puzzle precompute time: 1327
2020-06-17 12:00:01.641116|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
2020-06-17 12:00:03.281897|INFO | | |Increased protection level to: 1
2020-06-17 12:00:04.822628|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
2020-06-17 12:00:04.823369|INFO |Query | |listening for ssh query on 0.0.0.0:10022, [::]:10022
2020-06-17 12:00:04.823574|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32,
2020-06-17 12:01:07.897849|INFO | | |Decreased protection level to: 0
2020-06-17 12:02:31.569636|INFO |Query | |query from 1 xx.59.31.160:42970 issued: use port=3456 client_nickname=TS3index.com\s#272092
2020-06-17 12:02:56.974395|INFO |Query | |query from 2 xx.59.31.160:48674 issued: use port=8901 client_nickname=TS3index.com\s#274305
2020-06-17 12:04:31.250316|INFO |Query | |query from 3 xx.59.31.160:37992 issued: use port=9998 client_nickname=TS3index.com\s#273771
2020-06-17 12:05:38.875151|INFO |Query | |query from 4 xx.59.31.160:52896 issued: use port=7890 client_nickname=TS3index.com\s#274062
2020-06-17 12:05:51.653115|INFO |Query | |query from 5 xx.59.31.160:57420 issued: use port=7891 client_nickname=TS3index.com\s#272334
2020-06-17 12:12:26.811683|INFO |Query | |query from 6 xx.171.51.76:22056 issued: login with account “serveradmin”(serveradmin)
2020-06-17 12:12:26.951313|INFO |Query | |query from 6 xx.171.51.76:22056 issued: version
2020-06-17 12:12:27.000653|INFO |Query | |query from 6 xx.171.51.76:22056 issued: hostinfo
2020-06-17 12:12:27.124712|INFO |Query | |query from 6 xx.171.51.76:22056 issued: instanceinfo
2020-06-17 12:12:28.991364|INFO |Query | |query from 6 xx.171.51.76:22056 issued: serverlist -uid -all
2020-06-17 12:12:29.929643|INFO |Query | |query from 6 xx.171.51.76:22056 issued: use sid=30 client_nickname=CB -virtual
2020-06-17 12:12:32.305010|INFO |Query | |query from 7 xx.59.31.160:39114 issued: use port=3456 client_nickname=TS3index.com\s#272092
2020-06-17 12:12:58.148016|INFO |Query | |query from 8 xx.59.31.160:43556 issued: use port=8901 client_nickname=TS3index.com\s#274305
2020-06-17 12:13:44.465622|INFO |Query | |query from 6 xx.171.51.76:22056 issued: use sid=39 client_nickname=CB -virtual
2020-06-17 12:14:32.080720|INFO |Query | |query from 9 xx.59.31.160:55748 issued: use port=9998 client_nickname=TS3index.com\s#273771
2020-06-17 12:15:40.211892|INFO |Query | |query from 10 xx.59.31.160:40618 issued: use port=7890 client_nickname=TS3index.com\s#274062
2020-06-17 12:15:52.647672|INFO |Query | |query from 11 xx.59.31.160:44346 issued: use port=7891 client_nickname=TS3index.com\s#272334

Which of the commands showed any error? Tried some but they seem fine.

The log won’t show you errors on commands. it only shows who entered which command.

1 Like

the query program used use to show the channel tree of the actual server, there is no chance to try any other functions without joining as a query user and that is what is blocked in YaTQA right away. I have also reinstalled it in the meantime but the error persists.

If you run the server with the logquerycommands parameter, what you should do is do whatever you do to cause the error you’re seeing. Then post the complete unedited log files (all of them with the most recent timestamp). Feel free to upload them somewhere (ie. google drive) and send me the link in private if you’re concerned about privacy.
Also mention the time (including timezone) when you created / saw the error in question.

1 Like

Your use command fails because you’re trying to specify a 2 character nickname, which is less than the minimum required by the TeamSpeak server. Either don’t specify a nickname for your query client, or use one that is within the accepted range.

3 Likes

Oh! Wow! I did not think of that…! Bummer… This is why I like IT. Every character, or lack of character is able to make or break things. :smiley:

Chris, thank you very much for your time and your help! It did fix the issue indeed.
The solution in this case is to have the default serveradmin name NOT to change to an only 2 character - maybe someone will find it helpful in 10 years time from now. :slight_smile:

1 Like
twitch instagram twitter facebook