Server binding ip

Hello, I have a dedicated server with a failover IP configured under my NIC. The server currently accepts connection on the failover IP and other services (such as a csgo dedicated server for example) functions. What I would like to do is to allow ts3 server to accept ONLY connection from the failover IP, not the main IP binded to the dedicated server. I was trying to accomplish this by using the .ini file, but I had no luck and also googling for a solution didn’t help in my case. Has someone dealt with something similar or have a guide to suggest?

Thank you in advance!

I guess the easiest solution is to drop the incoming connections in your firewall.
Of course only if the destination is your non-failover IP address.

target     prot opt source               destination
DROP       all  --  anywhere             non.failover.ip             udp 9987

-A INPUT -p all -m udp -d non.failover.ip --dport 9987:9987 -j DROP

(assuming your UDP server port is 9987)

That’s just an example and will work with the UFW as well as the Windows firewall.

2 Likes

Thanks a lot, it worked

1 Like

Just as additional information…

Since you should have an active firewall running anyway I assume you already have an active incoming rule for your TeamSpeak server. That means an extra rule to drop the connection is not needed.

For example:

-A INPUT -p udp -m udp --dport 9987:9987 -j ACCEPT

Instead of creating an extra firewall rule you can add the destination to your existing rule, too.

-A INPUT -p udp -m udp -d failover.ip --dport 9987:9987 -j ACCEPT

This rule will accept UDP connections to port 9987 only if the destination is your failover IP address.

The benefit is one firewall less.

I also solved it by adding parameters to the .exe

ts3server.exe voice_ip=x.x.x.x query_ip=x.x.x.x filetransfer_ip=x.x.x.x

I don’t understand why it doesn’t work with the .ini file

Just in case: you do have to tell the server to load the inifile (using the inifile=filename parameter), it won’t just magically do it on its own.

2 Likes

I’m not stupid, I put the parameter on the exe but it didn’t work anyway, and the file loads it because I have the license in another path and it reads it

ts3server.exe inifile=ts3server.ini

OS : Windows Server 2019

twitch instagram twitter facebook