Server crashes immediately upon launch

hey, i am trying to run a server on my vps server, but as soon as i try to start the server it crashes immediately.

the OS itself is x64, though i tried both versions and same thing happening. i read something about no support for POPCNT, but they said the 32bit version would work regardless, but its not, it simply says “TeamSpeak 3 server could not start”. also tried older version where POPCNT wasnt required but couldnt launch the server because of expired certificates or something.

what should i do now?


solution is:

sudo dpkg --add-architecture i386
sudo apt install -y lib32z1 gcc-multilib
sudo apt install ca-certificates

for minimal version of ubuntu.

You need to be a little more specific.
Did you download from the official sources?
About what server version are you talking?
What command are you using to start the server?
Is a crash dump generated?

1 Like

hey, sorry if it wasnt obvious, but yes i am using the official source, talking about newest release that is downloadable, which is 3.12.2 i guess, but also tried 3.10 something, and using command ./ start, when i try to start it simply says “TeamSpeak 3 server could not start”, even if i try to start as root.

now i tried to install 3.9.1, and when i start it says “Failed loading default license file!”, it doesnt say it crashed, but i cannot connect to server and when i try “./ status” it says “Server seems to have died” and i cannot connect to server

no crashdump generated

and this is the log:

2020-08-08 21:01:37.880073|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.9.1 (2019-07-02 13:17:23)
2020-08-08 21:01:37.880134|INFO |ServerLibPriv | |SystemInformation: Linux 4.4.0 #1 SMP Tue Jun 9 12:58:54 MSK 2020 x86_64 Binary: 64bit
2020-08-08 21:01:37.880150|WARNING |ServerLibPriv | |The system locale is set to “C” this can cause unexpected behavior. We advice you to repair your locale!
2020-08-08 21:01:37.880158|INFO |ServerLibPriv | |Using hardware aes
2020-08-08 21:01:37.880605|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2020-08-08 21:01:37.880631|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2020-08-08 21:01:37.880762|INFO |DatabaseQuery | |checking database integrity (may take a while)
2020-08-08 21:01:37.892376|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2020-08-08 21:01:37.892423|CRITICAL|Accounting | |Failed loading default license file!

For locale C:…light=locale+c

1 Like

@FakE is correct here.
Also the screenshot you correct-fully removed again showed the real problem:
(I cropped it to not show unwanted information)
./ts3server: not found
I know this was a problem some time ago on this forum but I can’t remember the solution.
Maybe someone else can step in here.

1 Like

yeah i realized i shouldnt show that, i cannot post a log or crashdump because there is simply none, but in another thread i read that the cpu does not have the POPCNT instructions or something, but the 32bit version doesnt require that so it should work fine, but apparently it doesnt for me. honestly i dont know whats wrong and im getting overwhelmed by this. the OS is ubuntu 16.04 (minimal) if that matters.

What happens if you do not run the startscript but rather
./ts3server directly.
This should not be used for deployment but is great for testing.

1 Like

surprisingly it says no such file or directory, even though its there, atleast by typing “ls” it clearly shows up.

Can you show me ls -l

1 Like

Is this the 32 bit version?

1 Like

yes it is, as i implied before, according to some developer 32bit doesnt require POPCNT instructions. 64 bit version crashes immediately but i know it is because of that. in theory 32bit should work fine

Yes ok, as you said you are running 16.04 in a minimal version. I guess the necessary package to run 32 bit ELFs is missing.
You can install it like this:

sudo dpkg --add-architecture i386

Then the startscript should also work without any problems.

1 Like

tried to do this, nothing happened, and the server says the same

Starting the TeamSpeak 3 server
./ 44: ./ ./ts3server: not found
TeamSpeak 3 server could not start

I presume the same is happening when you try to start ./ts3server directly.

Could you provide me with the output of:
ldd ts3server

Installing those might help:
sudo apt install ia32-libs or sudo apt install lib32z1
sudo apt install -y gcc-multilib

Installing this should work:

sudo dpkg --add-architecture i386
sudo apt install -y lib32z1 gcc-multilib
1 Like

indeed it does, it says server is running, now i need to find out how to change server’s port to what i have opened and the server should be up and running. your sir are the hero of the day. thank you so much!

Glad to help!

Here is a quick explanation on the ini file for configuration (It’s not official, just what I could find the quickest that’t not from ~2009):

1 Like

hey, just a quick heads up in case someone has the same problem as me, i reinstalled the OS to check if everything works if i do it all over but one cruical part i forgot was that you need to “apt-get install ca-certificates” otherwise the server crashes immediately, no clue why though. thank you everyone for helping, especially Gamer92000.

1 Like