Server Not In List

I have viewed many posts on this subject over the years. I have taken all the advice I’ve found on figuring this one out, but to no avail.

I host my own server locally on another PC. My Internet is 1gbps Down/50mbps Up.

I have forwarded port 9987 UDP, 10011 TCP, and 30033 TCP to this machine. Am I missing any?

I have granted access in Windows Firewall to TeamSpeak3 server.

Regardless of how I search servers, via country, region, name, etc., my server is not found. In my own region, there are only about four servers.

Question: Is there something that prevents me from seeing my own server in the list because it is on the same external IP?

Thank you for your time.

No.

The Windows firewall doesn’t block outgoing connections (reports to the weblist).


In simple words the TeamSpeak weblist built in into the TeamSpeak 3 client is trash.

The list is missing lot’s of servers if you don’t add specific filters.
Which is non-sense if you try to find a server sorting the list by any column (e.g. clients/slots).

How can I find a (random) server if I need to set specific filters for it?


Let’s hope the server list of the new client will be improved a lot.

Even if I enter the exact name of my server and clear all other filters, it does not appear.

Please open the port 2010 (ingoing/outgoing).
Make sure to enable reporting the server list.
Set your network to connect/ping weblist.teamspeak.com (51.68.181.92)

If there’s no response, then something may gone wrong.

The default filter is sorted by country, region and city. So I guess you will not see your server if you don’t apply the filters which belongs to your TS3 server. But you’ll find it, when you type the name exactly in the “contain” field.

Please let me know if you have more issues. The weblist is pretty complicated… Guess like 90% of all server admins don’t know where the filters were applied to, so they don’t see their servers.

Location is (sadly) powered by IP2Location - you can check the given location at this site.

Why should he open up the remote ports TeamSpeak uses to accept requests (only)?

Domain Protocol Local Port (Server) Remote Port Notes
weblist.teamspeak.com UDP 2011-2110 (first available) 2010 all server versions

As I said the Windows firewall doesn’t block outgoing requests by default.

That’s probably not documented there.

UDP outgoing 2010 should be open as well. No idea why tbh.

Those have also been forwarded previously.

Here is the exact title of my server. See if you can find it in the server list:

Emplehod Gaming Free Public Server

Server is on list.

You turned off that users in Guest group can create any channel. This makes it harder to find your server.
We recommend to change permissions that they can create a channel or your server won’t be found with default filter. (That’s intended)

2 Likes

Which permission specifically, if you please? Guests can create channels now, or they could. I didn’t change the permissions.

Under “Channel Groups”?

Would it be “Manage Channels”? This also has “Edit” and “Delete”. I’m assuming this means only channels they create?

And how did you find the server? I looked using exact name, looked at the entire list unfiltered, never found it.


I found it by changing the filters under “Advanced”, which I didn’t know were there. I still can’t get permissions working to create channels. I tried under Server Groups and Channel Groups, tried all the “Manage Channels (create, edit, delete)” options and it did not change.

#########

Me again, think I got it. Guess you have to “Reload” after “Apply”, which seems strange, but it seems to be working now.

Thanks a lot for everyone’s help.

All can be fond under Create section.
The minimum set of permissions is:

b_channel_create_temporary
b_channel_create_modify_with_codec_opusvoice

I see you already found out which permissions are needed and you found your server.

1 Like
twitch instagram twitter facebook