Server with MariaDB Plugin can't create tables

Hey,

i tried to install a new TeamSpeak Server with the MariaDB Plugin.
The connection works without any issues but the initial create_tables.sql does not work when it’s executed by the TeamSpeak Server. When i run the sql file as the teamspeak database user it work’s without any issues. So the problem should not be on my site.
I’m using the libmariadb from the redis folder.
MariaDB 10.5.8

Log:
2020-11-26 14:30:39.499156|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.2 (2020-11-18 11:37:32)
2020-11-26 14:30:39.499252|INFO |ServerLibPriv | |SystemInformation: Linux 5.4.65-1-pve #1 SMP PVE 5.4.65-1 (Mon, 21 Sep 2020 15:40:22 +0200) x86_64 Binary: 64bit
2020-11-26 14:30:39.499268|INFO |ServerLibPriv | |Using hardware aes
2020-11-26 14:30:39.499732|INFO |DatabaseQuery | |dbPlugin name: MariaDB plugin, version 3, ©TeamSpeak Systems GmbH
2020-11-26 14:30:39.499747|INFO |DatabaseQuery | |dbPlugin version: 2
2020-11-26 14:30:39.580173|ERROR |DatabaseQuery | |db_exec() CREATE TABLE channel_properties ( server_id integer unsigned, id error: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘NOT NULL, channel_parent_id integer unsigned, server_id integer u…’ at line 1
2020-11-26 14:30:39.580236|CRITICAL|SQL | |db_CreateTables() unable to create tables

Looks fine here.

Is this a new database or an update?
What maria DB version is used?
Make sure you extracted all files. Sometimes sql files are not replaced from user while extraction and then such error could appears.

1 Like

Like written above:

and

All files are extracted correctly. Also redownloaded the tar.bz2 file and extracted.

That’s what i executed: mysql -u teamspeak -p teamspeak < create_tables.sql
An this worked without any Problems.

Is there any update?
Or are you testing this issue internal?

We tested it and can not reproduce this on Linux or Windows with server version 3.13.2.
It was tested against MariaDB 10.4.16 and 10.5.8 with InnoDB and UTF8.

At this point we do not know why you get such error.

2 Likes

Okay.
I tried to install another LXC Container and i don’t have an issue there.
Same Host, same OS, same MariaDB version, same TS server version, same SQL authentication, same configs, same folder, same collation and collection…
I am perplexed

But it works on the new LXC :ok_man:

EDIT: Also tried to redownload TS Server on the bad LXC but won’t work

twitch instagram twitter facebook