ServerQuery Returns Error:1024 invalid\sserverID


I messed up a permission setting and set Teamspeak’s “ServerAdmin” group modifying powers lower than the grant, locking me out from being able to modifying anything.

From what I read, a way to come back from this would be to go into the serverquery as the serveradmin and run the “servergroupaddperm” command. However, when I run this command it echos with error 1024 invalid\sserverID.

Whenever I try to fetch information it echos “msg=ok”, but whenever I try to do any related to modifying the server it echos “msg=invalid\sserverID”.

Thank you

Edit 1 : I attempted to use PuTTY and YaTQA to connect to the ServerQuery and neither of them were able to connect.

Hello @Tachi25 and welcome to the TeamSpeak Forum

With this error message, the server instance says that it does not host/know the desired virtual server.

Possible reasons:
The UDP port entered here is not correct
The TCP query port entered here is not correct

Nah, you just need to select the virtual server beforehand with e.g. use 1.


You are absolutely right, I completely forgot about this server query command to select your virtual Server :sweat_smile:

thank you, that fixed this issue :slight_smile:
I have another follow-up problem, should I make a new thread or just continue it in this current thread?

Feel free to ask here, if our overlord @SYOX doesn’t like it he can just split the thread.


whenever I attempted to use PuTTY and YaTQA to connect to the ServerQuery and neither of them can connect. Any way to check/troubleshoot what the problem is for this?

Some (obvious) stuff upfront. The query answers with space separated key value pairs. Within values some characters are escaped, e.g. a space is denoted with \s. Thus msg=command\snot\sfound means the return message for you request is command not found.

That’s most likely just a typo in the command. Same goes for the parameter not found. Could you provide the exact command you are trying to execute? And which server version are you running?

1 Like

I was trying to add a privilegekey and I realized there was a typo like you said. I didn’t think you would have responded so fast, but I changed the question XD

How CAN you connect to the query? Keep in mind that the telnet query requires access to port 10011/TCP, the SSH query to 10022/TCP, and the WebQuery to either 10080/TCP or 10443/TCP.

1 Like

My only method of connecting to the query is to SSH into the server machine and telnet 10011 into the serverquery. Using the 2 options for YaTQA has timed out connect and putty also.

Ok so you can’t reach port 10011/TCP on the server, like you can 9987/UDP. Make sure that on every step of the way the both ports are open / redirected equally. Alternatively you could tunnel port 10011/TCP through SSH for increased security like this: ssh -L 10011:localhost:10011 This is also possible with GUI SSH clients like Putty, but you’d need to look up the specific config for that.