Setting up my own Teamspeak 3 Server doesnt work

Hello Guys,

A Year ago, i setup a TS3 Server and did all the neccessary actions and it worked.
Now I wanted to do it again, but it doenst work.
I have a new Router and a new PC.

The PC has a fresh Windows Install and Updates, i downloaded TS3 Server and started it.
I knew from a Year ago, that Windows Firewall doenst like the Server, so i completly shut if off.
After that i port forwarded to the IP that shows in ipconfig in my PC, which is UDP 9987 9987 TCP 30033 30033 TCP 10011 10011
MY Wan IP is, it shows it in my Router and on
I can connect from my own computer to the Teamspeak Server, when i use localhost or, but now with my IP
Also other People cant join my TS3 Server.

For Troubleshooting i looked into Firewall from my Router.
The Only Option is Disabling it, which i dont want, but tried anyway.
Still it doenst work.
Any suggestions what may cause Problems for me?
This is the error that i Get from my second PC trying to connect to the other one.
<10:14:11> Trying to connect to server on
<10:14:16> Failed to connect to server

If theres any Information, that i need to provide, just let me know

I did some testing, without succes though.
I enabled Defender Firewall, but included ts3server.exe
I created an Account on and setup a domain which is
It points to my IP, but still doesnt work.

Its just called Vodafone station, Vodafone now owns Unitymedia.

Heres a picture of the Port Forwarding i did and how it looks when you create a new one

Nop, just Windows Defender, I installed fresh windows yesterday

The settings in the router is basic enable/disable Firewall, i disabled the Firewall there and restartet the Router, but there was no Internet after 15 minutes of waiting, so i turned it back on and restartet again.

Did i do something wrong with Port Forwarding?
Port Triggering doenst help here right?

As even both TCP ports seem to be closed:

I guess something clearly is wrong with the configuration. Are you sure your public IP is still correct?