SHA256 miss matched!

Hi everyone!
i will just inform you all about SHA256 miss matching on:
teamspeak 3 server Windows x64
https://files.teamspeak-services.com/releases/server/3.13.7/teamspeak3-server_win64-3.13.7.zip
SHA256: 605af411794f10530657153d91a47e32664a2b365d528848a5fa7b0874ac7572
showing: 489f6f02b336f80812ad0307897e072c37042d1c39341e4efbe7c09d1e100f59

i wish very quick fix!
do not download teamspeak 3 server win x64 untill fixes!

1 Like

Made a quick Test and result was fine (downloaded Server on in my Phone and tested online)

605af411794f10530657153d91a47e32664a2b365d528848a5fa7b0874ac7572

4 Likes

Same, correct hash for me.

3 Likes


virustotal shown: 489f6f02b336f80812ad0307897e072c37042d1c39341e4efbe7c09d1e100f59

sha256 numbers for all other downloads is correct expect this one. i am not joking. you may downloaded cached file!

Downloading trough the download you linked to, as well as downloading from TeamSpeak Downloads | TeamSpeak gives me the same hash that is listed on the download page.

Have you tried redownloading the server to check again? And you really downloaded it from their official file server?


Edit:

Downloading from Download TeamSpeak Server 3.13.7 for Windows | Uptodown.com (not an official TeamSpeak download service) gives me the hash you are receiving

hi
Have you tried redownloading the server to check again?
yes i did meny times and scaned many times too as i said only this download have incorrect sha256.
i download my files always from original links and i have security paranoid becuase of my systems.
the link i only download from for teamspeak is from here:

and
https://files.teamspeak-services.com/releases/server/3.13.7/teamspeak3-server_win64-3.13.7.zip

Is it possible that that hash referees to the “old” 13.3.7 which did not had the version correctly set in the server overview? So that the old versions hash is 489f6f02b336f80812ad0307897e072c37042d1c39341e4efbe7c09d1e100f59 and the version that got rebuild now has 605af411794f10530657153d91a47e32664a2b365d528848a5fa7b0874ac7572?

I can confirm different sha256 than provided on download site.

1 Like

Thanks man!

look Fubister replay he confirmed the sha diffs!

Okay that hash changes, depending on the (physical) location you are downloading from. Tried with a proxy (London) and also got 489f6f02b336f80812ad0307897e072c37042d1c39341e4efbe7c09d1e100f59

i living in Stockhom/Sweden
and no used proxys or vpns!

1 Like

I tested it in Poland, dedicated server in France and here at home in the UK, they all show different sha256. My theory is that it’s different download server for EU and NA? The zip file may be the same but it was packed twice (In short not the same zip file was used?) Each time you zip a file will result in different sha256, small oversight.

1 Like

any sha256 changes of a file in world wide means the original file is replaced with something else and it is a security threat.

1 Like

Ok talked with IT and remembered what has happened here.

Cache has been wiped and website was updated to hash

489f6f02b336f80812ad0307897e072c37042d1c39341e4efbe7c09d1e100f59

There is no security issue going on. But thank you for showing that problem!!!

Both hashes are right and nothing is wrong with the zip files itself.
Only with the server binary not showing right server version.

Story in short:
The windows 64 server was replaced because it was broken.
For that case instead of re building all servers again we only did build this server and uploaded it to bucket.
This did not update the website as it would when building all servers in a new commit.

More Details:
The bucket had the right zip with hash 489f... and a fixed build number 3.13.7

The zip with 605a... was still cached on some locations.
This version had a broken build number showing on Windows 64bit. It showed version 56769fee and not 3.13.7

5 Likes

Shorter version
Issue is fixed and there was no security issue. Only wrong cache in my case and not updated website.

3 Likes

Thank you TS.ChrisR.
i am happy now, you fixed this, it was scary a bite.

twitch instagram twitter facebook