[SOLVED] [Bug] TS5 Beta Linux Client Renders Text with Accents

Client Version
Version: 5.0.0-beta54.1 (Linux)

Steps to reproduce

  1. Type a vowel followed by a special character such as: ~, ^, _, [, ], {, }, | (this list is not complete and also works with some consonants)

Expected Behavior
[hello]

Current Behavior
[hellö

Comments
This might just be a setting that is enabled by default in the Linux client and not in the Windows client, but I could not find a way to disable it.

Hmm.
Works for me on Pop!OS 20.10.
What OS are you running?
What fonts have you installed?
What’s your WM and DE?

What OS are you running?
Arch Linux

What font’s have you installed?
My default system font is IBM Plex Sans, but that is not the font that the TS5 client is using

What’s your WM and DE?
i3

I just tried to reproduce this on my Arch laptop to no avail.
But I use wayland with sway. So this might not comperable.
Could you try checking out how the affected text looks in the debugger?
You can enable debugging by starting TS5 with the option --remote-debugging-port=<port>. Then you can connect to that with any Chromuim based browser on localhost:<port>.

Keep in mind that (afaik) TS does not ship with the required fonts but expects them to be installed on the system.

This leads me to believe though, that it’s a problem on your end.
To me it seems like a problem / misconfiguration somewhere in your text rendering pipeline.

1 Like

Also I found this:


which is the complete opposite of your problem, so it may be a keyboard layout thing?

I started the client with the --remote-debugging-port=8888 and sent the message [hello] in the chat (which displays as [hellö).
I opened localhost:8888 in Chrome and went to the message in the inspector and it does show up as [hello], so I would guess the problem is on my end as you are suggesting.

I was looking into that earlier and running localectl status displays the following, which seems right:
System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us

Also setxkbmap -query returns, which also seems correct:
rules: evdev
model: pc105
layout: us

I will try to look into this some more, but again as you said, this is most likely a configuration issue on my end.

Are you sure you have the correct keyboard variant?

Running setxkbmap -print -verbose 10 does not show a varient set:

Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     us
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+us+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)"	};
    xkb_types     { include "complete"	};
    xkb_compat    { include "complete"	};
    xkb_symbols   { include "pc+us+inet(evdev)"	};
    xkb_geometry  { include "pc(pc105)"	};
};

I ran localectl list-x11-keymap-variants | grep -e ^us to list variants starting with us which resulted in:

us
us-intl
us-mac
us_dvorak

But when I run setxkbmap -layout us -variant us to set the variant, I get:

Error loading new keyboard description

:confused:

To give some more details:
I didnt have a chromium based browser before trying the --remote-debugging-port test that Gamer92000 suggested. I installed Google Chrome and I see that the accent issue is happening there too, but only within web pages not the address bar.

^^^ This was the issue ^^^

Since this issue was happening in Google Chrome, I was able to inspect and the page and saw that the default font was Roboto. I edited the webpage to change the font family and the issue was resolved.
I listed the Roboto fonts I had installed with fc-list | grep -i roboto and removed them.
Now text is rendering correctly in the TeamSpeak 5 client and in Google Chrome.

Thank you all for the help :slight_smile:

3 Likes
twitch instagram twitter facebook