[Solved] Hosting a TS3 Server at home

Hey! I’m fairly new at this whole hosting thing, so I do have a few questions. Here’s the full story:

I have my own domain that I use to host a minecraft server, and it points toward my public ip. That way I can give that out instead of just handing out my public IP just in case anybody wants to join the server. Lately, discord has been pissing me off, so I want to switch to team speak (Far superior in terms of quality). Ive been able to port forward on 25565 for MC and 10011 and 30033 for TS3, but I cant get 9987 to open properly. I contacted my ISP and they said everything looked fine on their end, no firewall blocks and nothing setup incorrectly. I used a port checker and it says 25565, 30033, and 10011 are all open and working, but 9987 isn’t. I have heard that they cant check UDP ports so I had my buddy try and join, but he couldn’t.

That being said, I believe the problem to be one of two things. Either A.) The port isn’t actually open and I have to figure it out, or B.) The server isnt listening on the correct ip (I checked the log_1 file and it says its listening on 0.0.0.0:9987, which makes no sense to me but I dont know enough to argue about it lol).

There is a third option, option C.) Im big brain and have no clue what Im doing and I broke it.

I would love to have some help if anybody could, I really do appreciate it! Let me know what information you need from me and Ill be glad to supply it!

Solution

Blockquote Well you have to do only 2 basic things for your friends being able to join your server.

Step 1

(1) open your Windows (defender) firewall settings
(2) click on the link which is highlighted red in my screenshot

Bild

(3) click the confirm settings button
(4) click the allow another program button
(5) browse to your server directory and select your ts3server.exe

Bild

Step 2

Forward the ports the server needs to your PC the server runs on in your router.

TeamSpeak

Which ports does the TeamSpeak 3 server use?

TeamSpeak 3 Clients will contact the server in the following ways: Service Protocol Local Port (Server) Remote Port (Client) Voice UDP 9987 …

Watch out not to accidentally swap TCP/UDP ports.

Your friends can join your server now just by entering your IP address.

If you don’t know your IP address click on the link:

https://icanhazip.com/

2 Likes

Questions I have

  • What OS is your server running on?
  • Are you running the TS server in a VM or container?
  • What router do you use?
  • Does your server PC have a firewall (turned on)?

Ideas I have

  • Make sure you actually forwarded 9987 **UDP** to the server PC.

Also 0.0.0.0:9987 is just fine!

So its running off of my C Drive in its own folder. Im running windows 10 pro. In order to start the server I double click the .exe file like an absolute unit and it turns on. Im able to connect using my computers address (10.0.0.153) but nobody else can.

I have no clue what a container is, I do not run it in a VM. (Im a mega noob)

Its running off of my computer, win 10 pro.

Im using the Xfinity gig router hooked up to a switch, Ive had no issues for the past year (since I got the thing and switched from the netgear setup I had)

Ive gotten no Firewall notifications, but I could have something there, I dont know how to check.

The port forward is done correctly to my PC.

Well you have to do only 2 basic things for your friends being able to join your server.

Step 1

(1) open your Windows (defender) firewall settings
(2) click on the link which is highlighted red in my screenshot

Bild

(3) click the confirm settings button
(4) click the allow another program button
(5) browse to your server directory and select your ts3server.exe

Bild

Step 2

Forward the ports the server needs to your PC the server runs on in your router.

Watch out not to accidentally swap TCP/UDP ports.


Your friends can join your server now just by entering your IP address.

If you don’t know your IP address click on the link:

https://icanhazip.com/

4 Likes

damn, was just about to answer this…

Driving meanwhile :sweat_smile:

you will need static ip or ddns to try to static it some how tooo if ur dynamic ask isp about static ip for wan/ external ip IP

Does this IP address get the router from the provider ??

thats looks like lan address only so internal network only u need to open up ports on your router modem

Resolved now ive connected to his server and all works

Hello my friends cant join the server i did port forwarding internet is in public and did everything right but still does not let nobody join my server

See this Thread: [Solved] Hosting a TS3 Server at home

Ok so I set up a Ts3 free server on my old pc, first i sent my friends the ip but they couldnt connect. Then i forwarded the ports on my router, still didnt work. Next i made rules for the windows firewall to let connections in and out, that also didnt work. I need help I dont know what to do.

PS: I can connect with my new PC which is in the same network, but i also have to type in the ip from the server and not localhost.

And has anyone else outside your network even tried to connect?
Not all router have the ability that you can use your external IP to connect back to your own network.

You as the host machine always use your LAN or Local IP.
The external IP is for the external user connections

Which Ports have you opened? Please read.

It’s normal that other clients can not use localhost when the server is not running on their local environment.

5 Likes

Yes, two of my friends tried to connect from outside of my network. I opened the 10011, 30033 and 9987 Ports. And I am the only one, that can connect with the Ipv4 to my server. And I know that the localhost adress is only for the PC that the server is Running on. I also gave my friends the Ipv4 adress to connect to the server but that didnt work, that is my problem.

  • Make sure your ISP allows UDP traffic.
    This is blocked in some regions especially for Voice software like us.

  • Double check that you only opened UDP for the voice part.
    Some router have problems when both protocols (TCP & UDP) are opened in one rule.

Not sure then why you mentioned that part with localhost from other pc.

1 Like

Ok now Im lost, how do i make sure that my ISP allows UDP traffic, and what do you mean by double checking that i only opened udp for the voice part?
Btw. I noticed that you are from Berlin, would you like to continue in german?

  • Open your router / firewall and check what setting is there for port 9987 or for the server in general.
  • Read the manual for your router / firewall.
  • Ask your ISP or try other applications where UDP is requiered.

  • German is currently not part of this forum and i don’t think this would bring anything forward.
3 Likes

I have created a virtual server and I am not able to invite people to my server, even by using the INVITE BUDDY option. I give them my public IP address still get an error on their Teamspeak 3 Client.
I have port forwarded 9987 and 30033 ports of my router(D-Link 615), but still didn’t get any solution.

Hope you will contact me and figure out a solution .

Please take have a look in this Thread: [Solved] Hosting a TS3 Server at home

twitch instagram twitter facebook