[solved] TeamSpeak Client does not start on Linux

I just freshly installed Linux (Ubuntu Cinnamon 20.10) on my PC and downloaded Teamaspeak from beta.teamspeak.com. When I try to start it it instantly crashes, not even a window is opened.

This is what my console outputs.

Is there sth I might have forgotten? My system is up to date.

1 Like

Could you try running the client with the --no-sandbox option?

Same result

The issue seems to be with the chromium backend.
Are running a dedicated GPU?

Yes I am. I installed the nvidia drivers 455.28 (seems to be the most recent)
I could try disabling the driver and use the default x-server driver

The only GPU I heard makes trouble was the 1080 I think.
I can run it on Ubuntu 20.10 (PopOS) with MX150 and the latest Nvidia drivers without any problem.
I read somewhere on github that sudo and --no-sandbox in combination could help (even tough I don’t recommend it)

Hm, okey, I’ve got a 960. It acutally worked last time before reinstalling Linux, I’ll try using the 450 version, it seems to be the most stable.

Edit: both sudo --no-sandbox and the 450 driver didn’t work either

This is odd. Could you tell me what distro you are running?
I could quickly grab my laptop and do some testing on my own.

I’m running Ubuntu Cinnamon 20.10.
Might there be a issue with the compiled version from beta.teamspeak.com?

I don’t think so, but I’ll test it.
Is this just the downloaded or an updated TeamSpeak version?
The one on the website is not the most up to date.

It’s the one from the website.

Got a different error now using the X.org-X-Server drivers, no nvidia drivers installed

(EDIT: same with and without sandbox)

Ok, now running Ubuntu cinnamon I can reproduce this error.
Now onto finding a fix.

Having the same issue on Pop_OS 20.04. Maybe updating to 20.10 will help. Here’s what I get:

sudo ./TeamSpeak

No protocol specified
[1107/142611.522119:WARNING:gpu_process_host.cc(1262)] The GPU process has crashed 1 time(s)

This is weird. For me both Pop OS 20.04 and 20.10 worked fine.
Are you using the Intel or nvidia version?

Using Nvidia version, with a gtx 970. Might be a problem with 900 series gpus. Ill try updating everything to the latest version and Ill try again.

I’m having the same issue on Arch Linux with KDE as desktop environment and a GTX1080, using nvidia drivers 455.38.
Booting up a fresh live USB of Manjaro KDE poses the same result, immediate coredump on start of ts5, so likely not a misconfiguration of my daily driver.

I’ve ran it through valgrind (a debugger) and got these two crashdumps:
Without verbosity: https://pastebin.com/MNDgz5sP
With more verbosity: https://pastebin.com/V3wXDN7x
ldd: https://pastebin.com/fNzixRrU


Yeah, same problem here. I’m using Ubuntu 20.04 and got a GTX1080 with nvidia drivers 450.80.02.(Maybe not the newest ones) But it seems ppl with newer drivers have the same issue.

[email protected]:~/Downloads$ ./teamspeak/TeamSpeak
Abgebrochen (Speicherabzug geschrieben)

I was able to test this on an older machine. With a GT540m and nvidia drivers 390 it still crashes.
Used Manjaro Linux with Kernel 5.8.

Seems to be that teamspeak is incompatible with newer Libs, possibly libc 2.31?

Can someone from teamspeak at least acknowledge the problem and tell us if they’re working on resolving it? Linux users are completely locked out from testing currently …


From what we can read, only people with nVidia GPUs have problems, so no, it’s not that

If anyone has AMD GPU (just like I do), for them it works out of box (I can confirm that, cause it worked for me like this), so maybe it’s something with GPUs and/or drivers for them (especially as from what we see above, it’s not single-distro related problem).

nVidia drivers are proprietary on Linux so maybe it would be a good idea to contact nVidia directly about this problem.

twitch instagram twitter facebook