Teamspeak 3.5.5 update failed on Mac OSX El Capitan

I had Teamspeak 3.3.x (or 3.5.x not entirely sure) installed on my Mac with OS 10.11.6 El Capitan.

Now i tried to update to 3.5.5 with the integrated Teamspeak Updater, but the update crashed.

After the failed update i downloaded Teamspeak 3.5.5 from the Teamspeak Website, moved the App to my App folder (the old Teamspeak 3 App got overwritten) but it fails to launch and states:

This Version of Teamspeak requires at least Mac OS 11.12.

So i tried to downgrade and downloaded every single older 3.5 and 3.3 Version from the 4Players and Teamspeak FTP but none of them will run. The only Version i found that wont give me this error was Teamspeak 3.2.x. But with this i cant connect to any server anymore.

My Teamspeak Client was just working fine 2 days ago. I was able to connect to servers and was definitely on a newer Version, but since the Update failed nothing seems to work in this regard right now.

BTW: Teamspeak 5 Beta is working just fine on the same System.

1 Like

I have no idea why the update should not work. But maybe it’s because of a missing certificate.

Try to install the client via installer again and then hold CTRL (CMD) key and do a right click on the Client. Then select to open it.

Edit: Maybe related?

3 Likes

Thanks for your reply :slightly_smiling_face:

I figured out why the installation failed.

Apparently the Teamspeak Client Versions for Mac suddenly need a newer Operating System (Mac OS 11.12 insted of 10.11). Seems that the update function worked the last times but for a new Installation the Teamspeak App requires Mac OS 11.12.

I completely don`t understand why the developers made this desicion?

Teamspeak 3.2.x required 10.8 and for 3.5.x suddenly the jump to 10.12?
That is 4 OS Generations = 4 Years.
Even Teamspeak 5 requires only 10.10.

Now i am stuck with an old 2.5 version and can`t connect to any Server because any newer version refuses to start.

Is it possible to provide a version compatible with 10.10 or at least 10.11 for Teamspeak 3?

With version 3.3.0, the Qt framework used by the TeamSpeak Client was updated to 5.12, which was the LTS release at that time. 3.3.0 was released on June 18th, 2019 (so more than a year ago) and the update was necessary to fully support new macOS releases.

https://doc.qt.io/qt-5.12/supported-platforms.html

Unfortunately, if you can’t update to macOS Sierra or later, you’ll have to stick with your current version or switch to TS5.

3 Likes

From a security perspective, it’s a good idea to keep all your software up to date as updates not only fix software bugs but also patch vulnerabilities.

Thank you for the information.

I will check this. In worst case i`ll run TS3 in an emulator or VM.

twitch instagram twitter facebook