Teamspeak (3 & 5) url protocol registry broken


i desperately need help.
after accidentally installing the new v5 beta app and realizing it didnt work with an automated teamspeak signup tool i uninstalled it andinstalled the classic client.

however, during that process my windows (11) registry key that processes the “ts3server” apparently was corrupted. teamspeak urls no longer work, trying to reinstall any of the 2 clients doesnt fix it!

i also cannot manually set any default app in the windows settings. it just tells me there is no app associated and asks if i want to search the app store.
i cant just tell it which app to use like i am used with other standard actions.

how can i fix the registry keys related to registerng the default action?

and is there a known reason why the automated signup script apprently failed to work with the v5 client when everyone tells me it worked fine when they had the v3 client installed?

thanks in advance!

Installing the TS3 client should have changed the registry for ts3server urls.
But you can also change that for yourself if this did not fix it.

  • Open your Registry Editor
Press: Win + R key
Type: regedit
Press: OK
  • Select:

(you may copy paste this as path on top of the editor)

  • Modify (Default) and set a “path to your client executable” and add “%1”


"C:\Users\chris\AppData\Local\TeamSpeak 3 Client\ts3client_win64.exe" "%1"
1 Like


thanks for the reply.
Unfortunately this didn’t solve my problem.
I’ve been trying this and similar things by comparing registry keys from ny notebook where it (still) works (except that the actual path is “c:\program files\teamspeak\teamspeak.exe” for TS5 and “c:\program files\teamspeak 3 client\ts3client_win64.exe” for the classic ts3 apps, the corresponding appdata folders contain no executables).
It’s weird… I see the same registry settings on both machines, but on one it works - on the other it doesn’t anymore.

One thing I noticed though:
On the (working) notebook, when I check windows (11) settings->APPS->standard apps and search for either “ts3server” or “teamspeak” in the search field, it shows entries like

“URL:Teamspeak Link”

and when i click it, it allows me to confirm the teamspeak executable as standard app.

whereas on this machine here it just shows

“+ Add Standard”

and when i click this, all it does is redirect me to the app store to install an app for this association.

For some reason, I JUST CAN’T set any standard app association for TS3SERVER or TEAMSPEAK here on this machine no matter what I try.

Isn’t there a way tro safely remove ANY registry keys related to teamspeak, wipe it off clean… and reínstall so that it properly sets all required keys again for all relevant users (its a single user system, which means I only created one “offline” user who is admin on this machine).

Thanks in advance…

You do not have to remove or uninstall anything.

As i wrote the TS3 setup overwrites the ts3server registry entry each time you install the client.

When removing the mentioned registry entry, the entry for default apps also disappears and appears again when Reg entry was added again. But need to close Windows options each time i change the reg registry entry.

Works as expected on my Win 11.

  • You may create a text file and copy paste following into it
Windows Registry Editor Version 5.00

@="\"c:\\program files\\teamspeak 3 client\\ts3client_win64.exe\" \"%1\""
  • Then rename the text file from xyz.txt to xyz.reg.
  • Double click the .reg file.
1 Like


well, thanks again.
but it seems my system registry got damaged in some other way during the original process.

why? because that is what i already did a few times. i also uninstalled both client versions various times, and installed the other afterwards. the result is always the same… the apps launch fine, i just dont get any URL handling for either anymore on this machine. and it doesnt matter if its v3 or v5 of the app.

i also tried setting this (and veryfing all other teamspeak related) registry key, just 1 minute ago for the last time. no change or success.

the default app page in windows settings shows no entry for teamspeak no matter what i try. it worked after the very first installation, and stopped after i uninstalled it and went for the classic ts3 app when the ts3server:\ link i had to use to set up a specific teamspeak didnt work with v5 (other perople reportedly had the same, issue, installed v3 and it worked for them - just not for me :frowning: ).

i must admit, i regret not checking properly and just blindly trust and use the download link on the teamspeak website.
personally i think (and so do a lot of people i talked to since this happened) it is a rather BAD move to supply the link to a BETA software as the main download link, while the actual approved and stable classic client hides in the ARCHIVE section.

this particular windows installation is just a few weeks old - i dont really want to break it (any further) as it was a ton of work setting everything up on this “main” machine, so i guess i’ll have to give in and give up on that matter.

thanks anyway…


some time has passed, still no luck…

i just thought i’d add 2 screenshots showing what seems to be broken in my system… i still dont have any idea how they got broken or how to fix them:

this is firefox stating that it doesnt know what to do with the ts3server:\ lin…k as theres now registered protocol to it.
well, the ts3server entries i nthe registry do exist - so thats odd…

this is windows settings->apps… it shows no registered apps to either teamspeak or ts3server.

when i click it, it only prompts me to open the windows app store. in most other cases it shows a list of apps, giving me the option to pick a default app… not here though.
teamspeak clients (both v3 and v5) have been installed several times during all these attempts.

somehow, windows refuses to use any ts3server protocol links even though they’re clearly present tin the registry. i even have compared all “ts3server” and “teamspeak” related registry settings between my win11 notebook (where it still works perfectly) and this win11 desktop (where it worked ONCE, but stopped working after i uninstalled the v5 client and installed the v3 client afterwards.

am i really the only one having this issue? :frowning: