TeamSpeak 3 and multiple DNS servers

I have the situation, where I want to provide an IP-Address of a TeamSpeak server via a DNS server. That works as long as there is only one DNS server configured in Windows (or all DNS servers provide the same information).

But if there are more DNS servers available, where not all provide the same information, because there is an internal DNS server running for whatever reason, it works on some machines, on some not.

It turned out that it seems that the client is just asking the first or highest prioritized DNS server, which is a problem when this server is not able to resolve that domain.

Is there an option to make the client ask the next server when the first is not able to resolve the address?

The client resolves the IP as any other Software.
It asks what your network card resolved in your operation system.

So in case DNS server 1 could not find any IP to requested DNS, then DNS server 2 should be asked by your operation system.

Just to be sure with DNS server you mean the DNS server you enter in your network or router settings?
You got any examples?

1 Like

Seems to that I have to improve my reputation to do more detailed answer.

And again there is a 403 when there is a longer answer.

Is multi-line a problem?

ping myts.domain works.

nslookup myts.domain shows the same behavior like TeamSpeak.

nslookup myts.domain works, assume that is my local DNS server.

The setup is the following, there are multiple network connections:

  • LAN1 is connected to router which is connected to the internet, that router provides information about the connection via DHCP
  • LAN2 is connected to some internal network, in that internal network is also a DHCP running which also communicates a DNS server, this DNS server resolves myts.domain to

I can control which DNS server is used by manually setting the metrics of the connections. But if possible manually setting the metric should be avoided, also I don’t want to have LAN2 a better metric in general.

Sorry for the spam, Markdown was the problem. When there was Markdown in the answer, I got a 403 error.