TeamSpeak 3 cannot write to the configuration file

Does anyone have a fix for this?

inb4 all the comments come in telling you that you’re in the wrong section of the forum.

Have you tried running TS3 as admin - is this a new installation?

I have seen this error myself but that was when I had selected to store settings in the install folder of TS3 rather than in the appdata folder.

run as administrator and check the folder properties , make sure read-only is turned off

Uninstall TeamSpeak, then reinstall.
When you get asked where to store Configuration (After you specified the Location where to install to) Choose Recommended: Save in user own files .
That should fix it. You should backup / export your ID and copy all the Files (only the Files) inside the config Directory from your current installation to %AppData%\TS3Client once you installed again, before starting the client.

moved by moderator

Capture d'écran 2023-11-10 135931
I got this error and I tried all the solutions but it doesn’t work. I uninstalled and reinstalled ts3, I launched as administrator and nothing works. please help me

If ariel is your Windows username, then it has no permissions to write the settings.db.
Please check your Windows User permissions.

1 Like