TeamSpeak 3 Client 3.5.1

Ok. i cleared my cache also and started with -safeload. still crashing on startup. i cannot do anything, because i dont’t even see the client. So i cannot change any options. Installing 3.3.2 works fine

1 Like

1 Like

That attached zip broken.
the crashdump is missing and only a log seems to be included.

Tested it and works as long i allow it in Mac Os preferences.


Sorry. new try

1 Like

Tnx i will forward this crash dump


The Tessumod plugin is crashing. Please contact the plugin author for this.

I made a mistake it’s -safemode not -safeload (shame on me) i will correct the posts i made.


Many thanks. That solved the problem.

1 Like

Hello, please after I updated Client to 3.5.1 I found out that when I connect to TS3 server I cant see any Server Groups or Channel Groups until I have permission to give/edit them.
Is this a new feature or bug?
If a feature, is there a variable on server to “enable/disable hiding the groups” co I can define which groups will be visible when right-click on user disregarding users actual rights (like it was before 3.5.1 client version)?


Changelog of 3.5.0 says

  • Improved client context menu to filter inaccessible groups and permission related tools.

This was changed the way how TeamSpeak version 5 does since first closed beta release.

You will only see a group when you have the permission to add users into.
At the moment there is no settings for this. Not sure if there ever will be one.


Thanks a lot for quick reply. I must have missed 3.5.0 changelog because 3.5.0 was crashing on start for me and I had to revert back to 3.3.2.
Now 3.5.1 works fine so far and I was not sure how to interpret this change.
It would be nice if new variable to show/hide groups present in next version of server. I would appreciate to enable some of them as well as I am happy to hide many of them.

1 Like

The sound quality still not good for me and for my friend. Either way, we just can’t hear each other properly. Any new menu item we are trying to use is simply huge quality degradation for both parties. My friend has a microphone of 140 euros and has a voice as if he had bought it at Tesco. I just don’t understand why the sound is so bad. I just don’t understand why the sound is so bad. …


3.5 has ruined the audio quality from my mic.
In previous version the background noise removal worked perfectly for my mic with no noticeable degradation in voice quality. In this new version, I either have background noise or completely degraded audio quality depending on the position of the slider. Please add an option to use the old noise removal system as it was literally perfect for me.

  • Set Playback volume in Client: 0db - default, no adjustment down or up
  • Set Capture volume for microphone in the Operation system/Audio driver: 100, no boost
  • The name about used Sound card/USB Headset: Realtek onboard audio AND Creative AE-5 with ModMic 5
  • What problem do you experience: Capture no longer removes background noise acceptably (Tested locally via capture test)

Since 3.5 the automatic voice volume leveling has been moved to playback, the normalization is of notably lower quality. It now has underlying noise, which just wasn’t present with the capture normalization.
One of our TeamSpeaks’ members also remarked, that sound processing on the sender side would be the normal way to go.


Since the latest 3.5.x Update, my Mic’s volume automatically adjusts itself. This results in me being either way too loud (includes clipping) or way too quiet. It also generates a ton of background noise when I’m whispering for example.
This is not just on other people’s end but also happening in Test Mode.
Reverting back to 3.3.2 fixes that issue and my volume is back to normal.

Is there anything I can do about it? The Playback AGC doesn’t help on other people’s end. I’m still too loud/quiet when it starts adjusting.


I too have to say that the new AGC changes are utter crap.

With the old system I barely had to change anything for most people… Here or there, maybe I had to adjust single people to +1 or +3dB max.

With the new system 90% of our users are EXTREMELY quiet, even though I have a main playback of +4dB and a per-user adjustment of another +20dB (wtf). The other 10% are unbearably loud, sometimes even with a personal adjustment of up to -26dB (max).

It just doesn’t make any sense. AGC is also unusable because it creates a really weird “fade-in” effect where the person speaking gradually gets louder and louder (including static background noise that definitely wasn’t there in the old system).

Nobody changed their setup, everything has worked fine in the past and now most people cannot communicate at all. I checked with several people, they have their mic levels on 100, some even with Boost in audio settings and if they record something outside of TS their voice has regular loudness.

We are all on 3.5.x

So in the past most of the loudness was the same for all users (with a miniscule amount of ppl where I had to change personal settings), since the new version I have to adjust personal volumes for basically EVERY client that is connecting - yet some people are still not loud enough even with maxing out all the volume sliders.


This is a messy update. We are getting non stop complaints about people unable to hear other clients and issues of voice reducing drastically or increasing drastically at times. I am getting complaints in my music channels and all Ops Music codec channels regularly. Please get it fixed, sometimes the audio received is spiking and sometimes its just reducing so bad that you cannot even hear it.



From the TeamSpeak 3 Client 3.5.0 [Beta] announcement thread:

And we fixed the bug where user with master password set in their client could not use their password any longer to encrypt the settings of their client. This bug only did exist in the old but already revoked version.

Apparently this has not been fixed properly, the bug still exists.

Operating system type and version: Ubuntu 18.04 LTS
TeamSpeak 3 Client version: 3.5.1

Steps to reproduce the faulty behavior:

  1. Make sure /home/USER/.ts3client is empty (BACK UP EVERYTHING INSIDE BEFORE DELETING!) so that a new profile will be created upon TS Client start.
  2. Start TS Client.
  3. A window displaying the license agreement will show up. Scroll down to the end, then accept.
  4. A window about myTeamSpeak features will show up. Click continue or quit.
  5. A window about myTeamSpeak login will show up. Do not login. Deselect “Stay logged in on this computer”, then click “Continue without login”.
  6. A window requesting for a username will show up. Type in anything you want, it does not matter.
  7. Now open the security settings: Go to “Tools” tab, then “Options”. In the window showing up click on “Security” on the left side.
  8. Select “Use a master password” and enter a short password (six characters are enough for this test).
  9. Close all windows clicking OK and shut down TS.
  10. Restart TS Client and enter the password you set before. TS won’t let you in.

Please fix this! If I had not created backups of my identities and settings before, everything would have been lost by now. Thanks!

EDIT: The bug even occurs when using an existing profile with a previously accepted master password. If you log out of myTeamSpeak in TS Client via settings and deselect “Stay logged in on this computer”, you’ll lock yourself out effectively. BE CAREFUL!

I can reproduce that and have good news for your lost data.

When you deselect that option to stay logged in then passwords are cleared (also master password by accident).
But the setting to use a master password stays set.

Wat you can do is to open the client database with an SQL Lite editor and open and change UseMasterPassword from 1 to value 0. It can be found in table Application .
Then you should not get asked for a key.


Can confirm setting UseMasterPassword from 1 to 0 in the database settings.db fixed the issue: I was not asked for a master password and could access TS again.

Thank you very much!

As you pointed out already the master password will be cleared after the database has been edited. I tried to set one up again and ran into the same issue after restarting TS Client. So if you want to use a master password which TS Client 3.5.1 accepts, make sure to also select “Stay logged in on this computer” under myTeamSpeak options, regardless of whether you actually log in with your credentials or not!

Out of curiosity I also tried setting UseMasterPassword from 1 to 0 to hack into a profile with a working master password I pretended to not know, but when starting TS an error message appeared telling me the settings were (rightly) corrupted and access cannot be granted. So in usual cases it is not possible to just bypass a master password by modifying the database. Well done!

Hoping to see a permanent fix in one of the future versions of TS Client. Keep up the good work!


i noticed that after client update, server groups ID dissapeared in Server Groups TAB (advanced permissions enabled, also tested on clean server):

Is there any option to get them back?