TeamSpeak 3 Client 3.5.1

I too have to say that the new AGC changes are utter crap.

With the old system I barely had to change anything for most people… Here or there, maybe I had to adjust single people to +1 or +3dB max.

With the new system 90% of our users are EXTREMELY quiet, even though I have a main playback of +4dB and a per-user adjustment of another +20dB (wtf). The other 10% are unbearably loud, sometimes even with a personal adjustment of up to -26dB (max).

It just doesn’t make any sense. AGC is also unusable because it creates a really weird “fade-in” effect where the person speaking gradually gets louder and louder (including static background noise that definitely wasn’t there in the old system).

Nobody changed their setup, everything has worked fine in the past and now most people cannot communicate at all. I checked with several people, they have their mic levels on 100, some even with Boost in audio settings and if they record something outside of TS their voice has regular loudness.

We are all on 3.5.x

So in the past most of the loudness was the same for all users (with a miniscule amount of ppl where I had to change personal settings), since the new version I have to adjust personal volumes for basically EVERY client that is connecting - yet some people are still not loud enough even with maxing out all the volume sliders.


This is a messy update. We are getting non stop complaints about people unable to hear other clients and issues of voice reducing drastically or increasing drastically at times. I am getting complaints in my music channels and all Ops Music codec channels regularly. Please get it fixed, sometimes the audio received is spiking and sometimes its just reducing so bad that you cannot even hear it.



From the TeamSpeak 3 Client 3.5.0 [Beta] announcement thread:

And we fixed the bug where user with master password set in their client could not use their password any longer to encrypt the settings of their client. This bug only did exist in the old but already revoked version.

Apparently this has not been fixed properly, the bug still exists.

Operating system type and version: Ubuntu 18.04 LTS
TeamSpeak 3 Client version: 3.5.1

Steps to reproduce the faulty behavior:

  1. Make sure /home/USER/.ts3client is empty (BACK UP EVERYTHING INSIDE BEFORE DELETING!) so that a new profile will be created upon TS Client start.
  2. Start TS Client.
  3. A window displaying the license agreement will show up. Scroll down to the end, then accept.
  4. A window about myTeamSpeak features will show up. Click continue or quit.
  5. A window about myTeamSpeak login will show up. Do not login. Deselect “Stay logged in on this computer”, then click “Continue without login”.
  6. A window requesting for a username will show up. Type in anything you want, it does not matter.
  7. Now open the security settings: Go to “Tools” tab, then “Options”. In the window showing up click on “Security” on the left side.
  8. Select “Use a master password” and enter a short password (six characters are enough for this test).
  9. Close all windows clicking OK and shut down TS.
  10. Restart TS Client and enter the password you set before. TS won’t let you in.

Please fix this! If I had not created backups of my identities and settings before, everything would have been lost by now. Thanks!

EDIT: The bug even occurs when using an existing profile with a previously accepted master password. If you log out of myTeamSpeak in TS Client via settings and deselect “Stay logged in on this computer”, you’ll lock yourself out effectively. BE CAREFUL!

I can reproduce that and have good news for your lost data.

When you deselect that option to stay logged in then passwords are cleared (also master password by accident).
But the setting to use a master password stays set.

Wat you can do is to open the client database with an SQL Lite editor and open and change UseMasterPassword from 1 to value 0. It can be found in table Application .
Then you should not get asked for a key.


Can confirm setting UseMasterPassword from 1 to 0 in the database settings.db fixed the issue: I was not asked for a master password and could access TS again.

Thank you very much!

As you pointed out already the master password will be cleared after the database has been edited. I tried to set one up again and ran into the same issue after restarting TS Client. So if you want to use a master password which TS Client 3.5.1 accepts, make sure to also select “Stay logged in on this computer” under myTeamSpeak options, regardless of whether you actually log in with your credentials or not!

Out of curiosity I also tried setting UseMasterPassword from 1 to 0 to hack into a profile with a working master password I pretended to not know, but when starting TS an error message appeared telling me the settings were (rightly) corrupted and access cannot be granted. So in usual cases it is not possible to just bypass a master password by modifying the database. Well done!

Hoping to see a permanent fix in one of the future versions of TS Client. Keep up the good work!


i noticed that after client update, server groups ID dissapeared in Server Groups TAB (advanced permissions enabled, also tested on clean server):

Is there any option to get them back?

You need to hover with the mouse cursor above target group to see the ID.


Audio leveling is still fucked, doesnt matter if AVVL is turned on or off, people will still complain about other being quiet or loud, people will get boosted randomly when they are being quiet. It would be nice if this would be fixed


after updating 19.03 increases the microphone volume by 200%. Previously, it was possible to disable the microphone auto-adjustment, now it is not. I checked in other programs there are no such problems. what to do?


A post was split to a new topic: I lost all my data