Teamspeak 3 Client on macOS missing certificates

Hey, I just re-installed the TeamSpeak 3 Client on macOS Catalina (10.15.6). When trying to start the application, the following error pops up:

If I remember correctly, this is due to missing certification updates that should be applied so Apple can verify the application as non-malicious, Kitematic faced the same prolem prior it’s recent deprecation.

This should be a fairly quick fix (win). Are you aware of this?

PS: The tags feature is not really used well here. I could tag this bug, macos, prio:critical or so for better visibility.

@TS_Chris are you guys even checking these bug reports, or can I for the future just expect that reporting them is useless?

1 Like

Hi Chriszo

Yes we are aware of this and we do check bug reports.
We are going to fix this but i can not say when an updated version will be released.

As a workaround:
Hold the CMD key and then Click on the App and select Open. This adds the app as secure and won’t ask you next time.


Hello I’m encounter the same problem. Here what’s happen when I try to open it : Unable to open “TeamSpeak 3 Client” as Apple cannot verify that it does not contain malware.
I’m a begginer on Mac os
If anybody has a solution?

This is another problem and known.

1 Like

Ok thank you very much.
It works.
Have a good day

1 Like

This is still an issue. It’s been almost a year. I am honestly a bit disappointed by TeamSpeak at this point, not only because of this issue of course but also the TS5 situation. I’m not sure what’s going on down in Tijuana, but it just seems like the TeamSpeak Community is not a priority at all.

FYI: I cannot use the app on my Mac anymore due strict device policies, therefore the fix mentioned above is also not working.

“TeamSpeak 3 Client” can’t be opened because Apple cannot check it for malicious software.

Hey, same Problem here: " “TeamSpeak 3 Client” can’t be opened because Apple cannot check it for malicious software. ". As it is 31.Oct 2021, it must be a new bug as the report is now more than 1Y old. I assume you fixed it in the meantime and it broke again as otherwise the assumption may arise, that you guys don’t even care.

Same problem here, any update on this?

Hey macbachi,

this is not at problem at all. This is how macOS works now. It is just the same like in Windows.
If you have admin privileges you can choose to launch the software else it is rejected to run.

The request you are referring to only says “I don’t know the programmer of this software and he didn’t let it check it before releasing it and therefore will not run it”. This is just a security measure to prevent malicious installs. To become such a verified programmer one have to fulfill certain criteria that not everyone want or needs to have (i.e. a charged apple developer account).

So if you want to install the software anyway you can override this security measure by holding CMD and click open in finder OR you can go to preferences > security > general and click “Open anyway”.

@LoneStarGazer this is not an open-source project and the company behind TeamSpeak is not a non-profit organization. Such an Apple Developer ID can be obtained once to generate the certificate and it will not expire even if the developer program membership expires. An enterprise developer membership is 299 USD per anno.

Personally, I think it should be in the interest of the company to provide secure, certified software to their community and not force to overcome certain security measures introduced.

I completely agree.

All I did was to point out that this is what macOS behaves like if developers don’t sign their software.

And yes - if they would do it that would save many people time and scare.

1 Like

Maybe I forgot the <\irony> tags in my previous post. What I wanted to say was, that the assumption may arise that TS does not give a piece of sausage on making stuff more trustworthy. If (commercial) software is not even signed, I just can imagine what priority secure coding has. Its exactly like running a webserver with a self-signed certificate: when going public, thats not even close to professional.


HI, I downloaded the client from this site. launched it, moved it to the App folder. When I click on the client app I get an error message saying: “TeamSpeak 3 Client” can’t be opened because Apple cannot check it for malicious software.

Can anyone help me?

This should work:

Thanks. I tried your suggestion and after first receiving the same error, I used Command+click+open on the icon that popped up in my app bar at the bottom of the screen. I then tried inputing the server IP address using Connections, but the app shuts down when I click connect. Am I doing something incorrect, is that normal? When I click on the app icon again, there’s still no server.

You need to use this version:

Thanks fior the linkj to the Beta. That worked! Plus the Command click open to let it run.