Teamspeak 3 Echo cancellation stopped working

Hi,

I reinstalled windows 10 and noticed echo cancellation is not working anymore. I tested if echo happens in Zoom and it has no issues with the echo using just the default settings.

I am 100% sure it worked out of the box before. Also compared it with the laptop where I have identical windows settings for the mic/sound. So suspecting Teamspeak client has issues with latest windows or something got broken in the latest update.
Please fix it, its extremely frustrating since I literally cannot use Teamspeak unless I put headset - which I hate to do it every time. Thanks

Teamspeak version:
image

Windows 10 version:
image

This post was flagged by the community and is temporarily hidden.

What you could try, is to Update the TeamSpeak 3 Client to the 3.5.7 Version, maybe this fix your issue. :slight_smile:

To enable the Beta channel, simply go to Tools -> Options -> Application and select “Beta” from the update channel dropdown.

And can you please post your TeamSpeak 3 Client Log. :slight_smile:

I hope this help you out:

There are two ways echoes can occur:

  • The sound from your speakers/headphones is being recorded by your microphone.
  • Your sound driver is recording all the sound that you hear for you.

You can find out which issue this is quite easily. Just turn your speakers/headsets off (volume = 0%), and ask your friends if you are still echoing. If you are not, it’s the first issue,; if you are still echoing you have the second issue.

Fixing issue 1:

This type of echo is nearly impossible to fix completely, but you can minimize it greatly if you follow a few general points:

  • Switch your speakers off when TeamSpeak is on and use a headset to hear.
  • Use headphones that shield well, meaning they prevent as much sound as possible from being audible to the outside.
  • Try and keep your microphone as far away as possible from the headset (or generally speaking, the sound-source).
  • Lower the volume of the sound-source.

Fixing issue 2:

These echoes are produced by your sound-drivers. They should be configurable by your driver too (its not a bug, its a feature). From windows users we have often heard you can select from which devices to record in the mixer (a mixer is the place where you can slide all these volume controls). Make sure the microphone is the only entry that is being recorded from. This can be located on various locations depending on your driver/OS combination, you will have to look for this.

This is the case. Here TeamSpeak needs to filter out whats coming from the PC so users wont hear their voice/sound back.

  1. I did not change the environment setup. I only reinstalled the Windows and started having this echo issues. Before reinstall it was working. Now it isnt.
  2. Does not happen in Zoom, so clearly Zoom is capable filter it in software.

Not the case.

Also didn’t help.

This post was flagged by the community and is temporarily hidden.

What? You dont like criticism on your “support” attitude?? Is this problem at least on TODO list?

Hey @MacGyver27

We did read this report and we do agree with what @Rikku responded with when he tried to help you. The other posts were not on topic and so got removed for that reason. That’s all.

We do not have this issue on any todo list because we tried that out on the latest Windows 10 updates and TS3 Beta and can not reproduce your issue. Anything sent within the client (voice and sound) is lowered.

Sure, the echo cancellation is not perfect and users may still hear themselves quietly, but unfortunately that was always the case in TS3, however we are hoping to improve this further within the new client which we are actively working on.

5 Likes

Well if you did test it why not to post information about it then?? Otherwise it looks like you don’t bother :wink:

Other thing as average windows user you should know that having “latest updates” means nothing. Important is the OS version number and also the build number. E.g. EU has now new laws about privacy which required Microsoft to extract some codes/apps from the OS, thus creating new OS version to the market. So once again, did you try to reproduce this problem with the OS version I provided?

If you consider yourself a serious company this is the least you should have in your testing environment… just couple VMs, not that hard to maintain.

Anyway more to the problem. Teamspeak even picks computer sound. So you play a song and TS starts picking it as external sound. What is worse this applies for other users talking in the channel. This was not happening before. For now I switched to headset but sometimes I leave it on the table it picks the sound from it as well resulting into other users banning me or muting cause I am making the echo loop. And no, I am not willing to use push to talk here… If Zoom can handle this new OS version, you should as well.

Thanks.

twitch instagram twitter facebook