Teamspeak 3 not running

Good evening, good morning,

I speak French so my English is not perfect.

I have been trying to download Teamspeak 3 for several hours.
Being new to linux I started looking for discussions on the internet but despite the good number of sites dealing with the subject nothing worked.

I am in Linux on Steam OS so Debian.
I started by downloading the .run from the teamspeak 3 website in 64bit.
After that I turned it into an executable in my console.
At runtime, it asks me to accept their conditions of use etc, which went very well! So he downloads me a file which is Teamspeak in itself.
I watch several tutorials and according to them you have to run

ts3client_runscript.sh

What I did first in my file explorer and then in my terminal with this command because it didn’t work:

./ts3client_runscript.sh

And here is what my terminal responds:

./ts3client_linux_amd64: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by ./libQt5WebEngineCore.so.5)
QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
Crashdump ENABLED, directory is: /home/desktop/.ts3client/crashdumps
DUMP defined! Dumpdir is: /home/desktop/.ts3client/crashdumps
2020-02-09 19:33:23.468087|INFO | | |TeamSpeak Client 3.3.2 (2019-08-25 21:13:34)
2020-02-09 19:33:23.468407|INFO | | |SystemInformation: Linux 4.19.0-0.steamos2.3-amd64 #1 SMP Debian 4.19.45-1~steamos2.1 (2019-05-24) x86_64 Binary: 64bit
2020-02-09 19:33:23.468584|INFO | | |Using hardware aes
2020-02-09 19:33:23.615595|DEBUG |PulseAudio | |connected to pulse audio server -
2020-02-09 19:33:23.646601|INFO | | |*** Time [SPAWN_EVENTCONVERTER]: 107
2020-02-09 19:33:23.678313|INFO |ClientUI | |OpenGL Info: LibGL, Vendor: Intel Open Source Technology Center, Renderer: Mesa DRI Intel® HD Graphics 520 (Skylake GT2) , Version: 3.0 Mesa 18.3.4
2020-02-09 19:33:23.696835|ERROR |RevocationListCache| |Failed to import revocation list from cache
2020-02-09 19:33:23.888319|INFO | | |successfully downloaded revocation list for accounting
2020-02-09 19:33:23.903286|INFO | | |successfully downloaded revocation list for myteamspeak id
2020-02-09 19:33:24.001270|INFO | | |*** Time [ICONMANGER]: 134
2020-02-09 19:33:24.018521|INFO |Addons | |Checking for addon updates…
./ts3client_linux_amd64: symbol lookup error: ./libQt5XcbQpa.so.5: undefined symbol: FT_Get_Font_Format

Obviously nothing opens.

I researched the internet, tried the advice they gave, searched almost every site, but nothing worked.

I need Teamspeak so it’s pretty important :stuck_out_tongue_winking_eye:

Thank you in advance for all your answers.
Have a good day / evening!

Is the library libdbus-1-3 installed on your machine? It look like it’s not.

https://packages.debian.org/de/sid/libdbus-1-3

Good evening,
How could I verify this?

I don’t know the SteamOS to be honest but since it’s based on Debian, please try:

sudo apt-get install libdbus-1-3

(or without sudo)

1 Like

He tells me that libdbus-1-3 is already the most recent version available.

Hmm weird, please try to update all libraries on the server.

sudo apt-get upgrade

Btw. here’s a list of required packages for QT5.

https://altlinux.pkgs.org/sisyphus/classic-x86_64/libqt5-webenginecore-5.12.6-alt1.x86_64.rpm.html


I think I can’t help you solving this, sorry.

1 Like

Please show us the result of ldd libQt5WebEngineCore.so.5 from within your TS folder.

Hmm - old version of freetype maybe?

1 Like

Shouldn’t apt-get upgrade update all packages/libs?
(just asking, I’m not 100% sure)

1 Like

Usually, but I don’t know if steam OS has a custom freetype version or something. Bit of an odd one.

1 Like

Hmm maybe… let’s wait for his response.
Maybe he hasn’t run the upgrade cmd yet.

Im wondering about this anyway:

libdbus-1.so.3: no version information available

@Faux @Škýl @davinciTS

Good morning all !
Please give as much importance to the problem.
I did the upgrade but everything was good, 0 updated, 0 newly installed.

Not super sure what to suggest. Are you on the latest Steam OS (i don’t know if it does dist-upgrade or what). I’d like to see what

dpkg -l | grep freetype

gives. Anyone else have experience with Steam OS?

2 Likes

SteamOS is based on Debian 8.
Also Sinusbot users have issues with Debian 8, so i searched a bit in the internet.
When the no version information available text is in the log, this means that the installed libary is older than the libary which was used to compile the client.
Debian 8 uses 1.8.22 (https://packages.debian.org/de/jessie/libdbus-1-3)
Debian 9 uses 1.10.28 (https://packages.debian.org/de/stretch/libdbus-1-3)

@davinciTS could you provide us the exactly version of dbus which is used to compile the client?

Edit: Sorry for reactivating this old post

1 Like

Good morning all !
I changed OS and am currently on Debian 9 Buster, and everything is fine. I think this is a big problem with Steam OS which is only in BETA. Thank you anyway for your help!

PS: Sorry not to have told you about it earlier, I had created more topic and forgot to answer this one.

1 Like
twitch instagram twitter facebook