TeamSpeak 3 open error

Hello, i have a problem with opening teamspeak 3. When i try to open teamspeak, it just give me error “The program can’t start because api-ms-win-crt-runtime-l1-1-0.dll is missing from you computer. Try to reinstall the program to fix this problem.”

I hope you can help me with this problem, have a nice day.

Have you already reinstalled the program?

(1) Navigate to your Windows system settings Apps and features.
(2) Remove all packages with a similar name to Microsoft Visual C++ Redistributable...
(3) Restart your PC
(4) Download the package vc_redist.x86 and vc_redist.x64 from Microsoft (URLs below)
(5) First run the x86 installer and x64 after
(6) Restart your PC (again)

-> Report back

All in one package 2015, 2017 and 2019

https://aka.ms/vs/16/release/vc_redist.x86.exe
https://aka.ms/vs/16/release/vc_redist.x64.exe

yes i tried even downloading older versions.

I deleted 2015 (i left only under 2013) package and did everything you said, but when i tried to run x86 installer, it said error 0x80070424 (Service does not exist). Any ideas how to fix it ? I got also log from that, if you want i can send it to you.

Edited I just paste that log in the pastebin : https://pastebin.com/QtkH7yzj Edited

1. [04C0:0860][2020-06-04T15:45:31]e000: Error 0x80070424: Failed to open WU service.

2. [04C0:0860][2020-06-04T15:45:31]e000: Error 0x80070424: Failed to ensure WU service was enabled to install MSU package.

3. [04C0:0860][2020-06-04T15:45:31]e000: Error 0x80070424: Failed to execute MSU package.

If you haven’t disable the Windows update service manually there are only 2 reasons for this issue.

  • your OS is completely „f*cked up“
  • a virus removed/disabled this service

You can try to start the service manually in the task manager but I don’t think this will help.

Just google the error code, please.

If I remember right there’s a „WU FixIt“ app out somewhere trying to deal with this issue.
(probably in the MS forums)

twitch instagram twitter facebook