Teamspeak 3 Server doesent Work

Hello Guys,
Im Getting this following Error Message when I want to start my Teamspeak Server;
2022-06-07 20:14:42.114052|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.6 (2021-06-09 10:22:37)
2022-06-07 20:14:42.114440|INFO |ServerLibPriv | |SystemInformation: Linux 4.9.0-18-amd64 #1 SMP Debian 4.9.303-1 (2022-03-07) x86_64 Binary: 64bit
2022-06-07 20:14:42.125210|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
2022-06-07 20:14:42.125266|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2022-06-07 20:14:42.128272|INFO |DatabaseQuery | |checking database integrity (may take a while)
2022-06-07 20:14:42.260189|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2022-06-07 20:14:42.262211|INFO |Accounting | |Licensing Information
2022-06-07 20:14:42.262335|INFO |Accounting | |licensed to : Anonymous
2022-06-07 20:14:42.262350|INFO |Accounting | |type : No License
2022-06-07 20:14:42.262370|INFO |Accounting | |starting date : Thu Oct 1 00:00:00 2020
2022-06-07 20:14:42.262378|INFO |Accounting | |ending date : Tue Nov 1 00:00:00 2022
2022-06-07 20:14:42.262385|INFO |Accounting | |max virtualservers: 1
2022-06-07 20:14:42.262391|INFO |Accounting | |max slots : 32
2022-06-07 20:14:44.604072|INFO | | |Puzzle precompute time: 2194
2022-06-07 20:14:44.606138|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
2022-06-07 20:14:44.609698|INFO |Query | |Using a query thread pool size of 2
2022-06-07 20:14:44.737466|INFO |ServerLibPriv | |failed to download revocation list - count: 1
2022-06-07 20:14:44.804852|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
2022-06-07 20:14:44.807374|INFO |Query | |listening for ssh query on 0.0.0.0:10022, [::]:10022
2022-06-07 20:14:44.807704|INFO |Query | |listening for http query on 0.0.0.0:10080, [::]:10080
2022-06-07 20:14:44.807748|INFO |CIDRManager | |updated query_ip_allowlist ips: 127.0.0.1/32, ::1/128,

I have deleted all teamspeak files/folders and tried to reinstall step by step but I still not works…

Where is it? Do not see any error at all.

3 Likes

2022-06-07 20:14:42.260189|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality

This is nothing strange. If you don’t have a license, none will be loaded, but you’ll have 1 virtual server with 32 slots as “limited functionality”.

Yes But when this isnt an error why I cant connect on it?

Is that all it says in your log? It doesn’t say that the server was stopped.

yes thats all and the reason why Ive made this thread… because Ive no Idea what to do

Open the ports (at least 9987 UDP) and connect to the right IP.
That’s literally it.

1 Like

How can I do that?

Well, for this you have to go into the firewall of your server and open port 9987 there. The procedure varies from operating system to operating system, but there are many instructions on the web.

I dont get it… Im using an Linux Root Server with Debian 10 64x

Alright. I’m not a Linux specialist, but open the administrator console on your server and enter the following command: iptables -A INPUT -p udp --dport 9987 -j ACCEPT Normally, this should work.

thank you so much it worked but now I cant connect to yatqa (Serverquery) It gives me “Timed out”

This is probably because only your 9987 port is open, which is for voice service. For query access you still need to open port 10011 (TCP). This might work with iptables -A INPUT -p tcp --dport 10011 -j ACCEPT

At TeamSpeak Server Ports you can find all other possible ports that your TS server needs.

That worked for me thank you so much <3

1 Like

Glad to hear, you’ re welcome! :smiley:

Pls excuse me for my disturbing but at the Morning my teamspeak wasnt running so I had to do the same process with port forwarding…

twitch instagram twitter facebook