TeamSpeak 5.0.0-beta23

We pushed out a new beta release.

  • You now can use hotkeys while another application is in fullscreen or uses admin permissions.
  • Free server now can be created or managed in the “Servers” tab.
  • Improved hotkey behavior in fullscreen applications
  • Hotkeys now also work in applications running as admin
  • Reworked user interface for free servers to be more robust
  • Performance improvements for contact lists and other areas
  • Fixed issue with image previews flickering
  • Image preview can be closed with the escape key, or by clicking outside
  • Editing channel descriptions should now be saved properly if you click the confirm button immediately
  • Fixed bug where hitting TAB could move scroll position
  • Minor tweaks to emoji handling and code blocks in chat input

Happy testing :smiley:

17 Likes

Ahm, was not supposed we have server group permissions on this update? :confused:

Cheers

Nope, that isn’t what I said. What I said was:

Just to keep you guys in the loop there’s going to be quite a bit of maintenance next week on the beta and then an update including a number of fixes and improved hotkey support.

^ that’s today’s beta.

Then if all goes well, you guys are getting server permissions in the next big update.

^ that’s the next big update.

5 Likes

Regarding to this thread

… I have noticed a bug with this new bookmark.

Btw. I would like to be able to hide this bookmark, too.
(in the settings or at least the dev tools - for now)

0125

Bug 1

(1) right click the create free server boomark
(2) hover over the empty context menu entry (click to copy)

Copies the string undefined to your clipboard

I never created a free server which is the issue, I know but should be tweaked anyway.

Bug 2

(1) right click the create free server boomark
(2) choose Manage in the context menu

Will try to connect to the server, even if you don’t have created a free server (like me)

0126

Regarding to my post further up…

Bug 3

Connecting to the free server I have never created will add the bookmark null in the dashboard.
(by clicking on manage described in bug 2)

I guess the app shouldn’t add bookmarks to the dashboard if the server address is empty.

0127

1 Like

Tnx will put that on devs table (forward it to our devs) :slight_smile:

2 Likes

@FakE I can confirm this is now fixed in the codebase for the next update

2 Likes

:+1: :+1: :+1:

I have just found another little cosmetic issue if it isn’t supposed to be like this.

0127

Using the server’s context menu to use a privilege key for example will be padding/margin (CSS language) the server tree on top.

0128

The scrollbar of picture 2 has moved below the red icon in the background right of Apply.

Like to say it in CSS the server tree has a margin-top: 20px; above.
Or at least something around 20px.


Is this supposed to be like this or not?
I thought the overlay is a “real” overlay which doesn’t affect the background (server tree)?

I assume other overlays/editable tooltips like requesting talk power is causing the same “issue”.
(couldn’t test this yet)

Just an unimportant cosmetic thing however.

1 Like

Interestingly, I alone can not change the name of the bookmarks of the free server? :thinking:

Hotkeys are not working on the latest update for me :frowning:

Details please?
Which device and what key? Has it worked before? What operation system?
Where is the client installed (i mean the path) and only when you are in game or when client runs in foreground?.. etc.

Windows 10 PC, mouse 5. It has worked before, installed in C:\Program Files\TeamSpeak.
It is not working at all, doesn’t matter if application is in background or foreground.

1 Like

Mouse 4 and 5 are known issues.
They have worked before but caused problems in Client Interface (Jumping back/forward).

Please use another (non mouse) key till we have a solution for this.

2 Likes

Is there an autoconnect function in plans? Ill miss this alot in my TS5.Also i would love to have an auto tab selection when i get a message either pm or server so it will automatically move me to conversation.

Try to install again Mouse 5, it helped me (After updating it didn’t work, I installed it again and everything works)

Mouse 4 didn’t work for me either after this update until I reset it. But now it shows this:


It works just fine though.

Weird how this update in particular broke the Mouse 4 and Mouse 5 buttons.
When in the past they worked perfectly.
Mouse 4 and 5 both show missing hotkey plugin.
But Mouse 4 works after rebooting app. where mouse 5 doenst work at all.
Makes teamspeak 5 unuseable for me as there are my prefered hotkeys, probally lots of others people too.
Back to teamspeak 3 for abit i guess.

Thanks for the feedback - we’re looking into this one!

1 Like

A post was merged into an existing topic: Wishlist

Hey, I’d like to download the update, but it says that no updates are available even though I’m in version 19, please can you help me ?

1 Like
twitch instagram twitter facebook