TeamSpeak 5.0.0-beta59

Hello everyone!

Beta version 59 is now available to test! This time we worked on a mixture of fixes and improvements which cover a few different topics.

Hopefully the changelog should explain the update well enough.

Here is the full Changelog with all changes and fixes

- Fixed remote applications port not being saved
- Fixed ban client context menu not being shown when missing b_client_ban_create
- Fixed some icons being animated even when the client does not have the focus
- Fixed remote applications still being visible after removal
- Fixed disabling remote applications not doing anything
- Fixed event viewer pop-out not adjusting when resizing the server tree
- Fixed incoming pokes not being visible when hiding moderation events
- Hide channel create options when you cannot create a channel
- Improved behavior of links in pinned messages
- Improved remote applications event properties to be human readable
- Improved tooltips of sliders in audio settings
- Remote applications port is now set to default when input is cleared
- Updated chromium

Notes for this thread

  • Feedback as per always is welcome in this thread :slight_smile:. Issues that are not related to this update belong to it’s own thread.
  • We suggest to place your wishes for upcoming releases in existing or new threads in the suggestion area instead of the release thread. We mention this because each update post will be closed after some days and the wish or suggestion could be lost.
  • We allow ourselves to delete all the off-topic posts from this thread.
20 Likes

:+1:

2 Likes

Hello I found an interface bug when changing a server group name or a channel group, the interface this offset

cordially

1 Like

Tnx for the report.

Can reproduce it + Edit or Deleting also triggers this + Deletion does not remove the group from that dialog.

5 Likes

A post was merged into an existing topic: TeamSpeak 5 not remembering user default channel

I found a bug in that version: When you trying to change “Needed Talk Power” option while editing the channel, it isn’t showing the current value. Also i cannot set another value (error on 2nd screen). In beta-58 all worked fine.
Снимок экрана 2021-07-13 154549

3 Likes

Thanks for the report. I forwarded the issue to our developers.

5 Likes

A post was split to a new topic: Sometimes i do not see my own chat and Channel commander icon is not shown in system tray

Post moved by moderator

I noticed that when I rename server/channel groups on the TeamSpeak server or change the icon of the group via the TeamSpeak 3 client, this is not applied in the TeamSpeak 5 client until I reconnect. However, changes to single permissions of the groups are already applied.

right_group

I also noticed that there is a very large space between individual server groups in the permissions list when changing them via TeamSpeak 3.

Additionally, one server group was duplicated after I renamed it via TeamSpeak 3. One group has the old name, the other has the new name.

My server version is up to date.

2 Likes

This post was flagged by the community and is temporarily hidden.

This topic was automatically closed after 7 days. New replies are no longer allowed.

Post moved by moderator

Hey!

I’ve found a display bug regarding groups.

If someone (or even yourself) are editing a group two things are happening.

  1. The spacing between the groups are very wide and if you do this multiple times, it is getting even worse.
    spacing_1

  2. In the user server groups context menu, the groups are getting duplicated. Like 1. it’s getting worse after everytime a group is getting edited.

Client information
Version: 5.0.0-beta59
Build Number: 1625645480
Build Date: 7/7/2021, 10:11:20 AM
Chromium Version: 91.0.4472.114

Possible reason
Didn’t look pretty deep into it and only speak of own experiences. I expect it has something to do with the socket connection. If something get updated, the client loads all groups in it’s frontend / cache again but doesn’t clear the old entries from the array and so vue refreshes the html and displays the complete array and all duplicates.

Possible solution
If this is the real reason, the solution is pretty simple. Go into the function which handles this and add the missing array clear.

Kind regards,
XeroxDev

I could not reproduce this, everything works for me.

As long we can reproduce this everything is fine.

6 Likes
twitch instagram twitter facebook