TeamSpeak 5.0.0-beta67

Hi everyone!

Today we released beta 67.
In preparation for the open Beta we decided to focus on and update our existing features. So everyone is aware, the next updates will most likely be similar in that we’re putting some final touches to the beta client before we move on to the next phase of development.

Changelog

* Fixed images pasted into chat not having a proper file name in some scenarios
* Fixed an issue where channel chat could show a different nickname than server tree
* Fixed not showing an error when changing your nickname on a server failed
* Fixed a minor issue in Linux desktop file
* Fixed an issue with open private chat not working correctly
* Fixed context menus not opening correctly in some cases
* Fixed not loading the current theme file from disk when refreshing themes
* Fixed missing multi select menu
* Fixed a crash on Linux / Mac
* Fixed icon cache not being used in some cases
* Fixed wrong / missing error codes when uploading files in some scenarios
* Fixed opening random chats when double clicking own client
* Fixed an issue creating folders
* Fixed an issue with room discovery not updating when switching modes
* Fixed an issue requiring a client restart after removing an audio device
* Fixed settings not updating when the system audio devices changed
* Fixed several issues with ignored users
* Fixed bookmarks having a broken icon when cache was cleared
* Fixed not showing some permissions
* Added loading indicator to server icon view
* Added default myteamspeak.com server when adding contacts
* Reduced the priority speaker icon size
* Removed animation from talk power request icon when client is not in focus
* Removed pin and delete message option from context menu for events
* Updated chromium

Additional Fix

  • We fixed a crash when AirPods got disconnected

Notes for this thread

  • Feedback as per always is welcome in this thread :slight_smile:. Issues that are not related to this update belong to it’s own thread.
  • We suggest to place your wishes for upcoming releases in existing or new threads in the suggestion area instead of the release thread. We mention this because each update post will be closed after some days and the wish or suggestion could be lost.
  • We allow ourselves to delete all the off-topic posts from this thread.
31 Likes

Since updating to this version Teamspeak always crashes within at least one minute. I’m on macOS Monterey beta 12.1 so this isn’t a problem right now. But if it goes live the affected user base is getting much more bigger.

If you want to I can attach a crash log.

Yes please.

4 Likes

Archive.zip

The entire logs folder of teamspeak plus the crash report from console. Hope this helps…

A little update: I tried Teamspeak 3 and the old problem of crash upon server connect happened again… lucky me found the version 3.5.7 which fixed the sound problem some time ago - and this version works flawlessly even under macOS 12.1.

Is it possible that the fix has been patched out of the new releases?

Thanks for the feedback. We are still evaluating that issue.
We do not think that it is related to what happens in ts 3.5.6 else would happen in any version before beta 66.

Can you run beta 66 https://teamspeak.com/en/downloads/#ts5
In case you can’t i move this bug report to it’s own forum thread.


Unfortunately I could not test it out. My MacBook Pro Mid 14 can not update to Monterey ;(

7 Likes

Hey Chris,

I tried version 66 and it ran well. I could connect, join and alter audio settings with no crash. Because of the automatic update the next run didn’t work as that was now beta 67. So there are definitely changes between these two versions.

Besides this problem there is an issue in both: changes to the dropdown in voice activity detection are not applied. So if I choose volume gate or automatic I’m always flagged as speaking.

If you want me to help - just call me. Maybe we can continue in German as I think this is our both mother language.

And please move this thread as I don’t know how to do it…

Do you have any other devices connected (like a gamepad).
Does it still crash when you unplug them?

3 Likes

Unplugged my G13-Gamepad and my YubiKey to test but teamspeak still crashes…

Can you share us the ips file again?

3 Likes

Sure: TeamSpeak-2021-12-06-085218.ips

2 Likes

It’s getting weirder: I booted my second Mac which is on macOS Monterey beta 3 and there I have no problems with your beta67.

Do you want me to update this machine to see if this breaks something?

No.

The crash happens in Chromium Embedded Framework (CEF). We updated to the latest stable version in beta 67 and unfortunately there is no newer version available to test out if an update helps.

We are not sure what to do now.

4 Likes

Oops. I upgraded yesterday evening and now comes the crazy part: On this machine your new version works really fine. Even stranger: this machine is a clone of my machine. So I am currently narrowing down where the differences lay. I’m coming back for further informations.

Okay. I think I got it: I’d created a multi-output device that seemed to cause the crashes. After deleting it and rebooting Teamspeak beta is stable now.

The problem with Voice Activity Detection not correctly applying still exists though.

We tried to reproduce this on Monterey 12.1 (21C52) but couldn’t reproduce this yet.

Can you still reproduce it with your machine(s)?
Is this only when the main device is not connected?
And what happens when you try this with only one or none AirPod device as active device in that list?

5 Likes

Since beta67 I get sometimes connection issues. If I lost the connection to the Server and I try on the same tab to reconnect It says mostly connection failed. To join the Server I need to close the current Server Tab and click on it again.

This isn’t related to b67. This is something the client lib does because it was build this way in TS3 already.

The socket the tab (aka connection handler) used is blocked and can’t be re used in your case.
A new tab does use another one and this is why a new tab works.

5 Likes

I recreated such a multi output device and also could not reproduce that error. Maybe one of the updates broke something which works if you start over.

To me it looks like a very uncommon problem which isn’t caused by teamspeak but the OS itself. And now that Monterey is live we will soon see if there are others with that problem. To me that case is closed and I want to thank you you for your support. This isn’t something that can be taken for granted!

1 Like

Thanks again for the feedback. The whole issue is still a strange one… because we just fixed an issue with AirPods in that release.

7 Likes
twitch instagram twitter facebook