TeamSpeak 5: Key binding causes buggy microphone mute behaviour


I’m only using the TeamSpeak 5 beta client and I have the same issue since at least a half year. I had the hope, that somebody else has this issue and it gets fixed soon, but it seems like as I’m alone with this issue or nobody else has reported it yet.

First of all some system information:

Windows 11 x64
TeamSpeak Version: 5.0.0-beta66
Build Number: 1635340287
Build Date: 27.10.2021, 15:11:27
Chromium Version: 93.0.4577.63

Problem description

I’ve configured a key binding to automatically mute and unmute my microphone in the TeamSpeak client, so that these people in the TeamSpeak channel don’t hear me twice: Once in TeamSpeak and once in the Game, which I play.

On an usual game evening (~ 3 hours) it occurs at least one time, that other people in the TeamSpeak channel tell me, that I’m still muted and that they can’t hear me, although TeamSpeak has automatically unmuted myself and I also don’t see any muted microphone symbol on my side.

Pressing / Clicking the microphone mute/unmute button or also the configured key binding doesn’t unmute myself. I always need to restart the entire TeamSpeak client in order to unmute myself, that other people can hear me again.

Steps to reproduce

It’s not really reproduceable. It randomly happens over the time while gaming (or just writing some text, where I sometimes press the configure key).

  1. Open the TeamSpeak 5 client
  2. Open “Settings” > “Key Bindings”
  3. Create a new profile and configure a specific key (in my case it’s the key “T”) like this (also see attached screenshot):

Microphone: Mute (on pressing “T”)
Microphone: Unmute (on releasing “T”)

  1. Enable / Activate this new profile as default profile
  2. Play some games, where you sometimes need to press the button to talk in-game or e.g. just write some text, where you need to press the button sometimes

If you need any additional information, feel free to contact me.

Best regards,