Teamspeak 5 Vanity Badges not showing in menu or in server

I recently have had an issue with logging into my myTeamspeak account on the TS3 client for some reason so I took it as a sign to really use my TS5 but I seem to be having an issue where my badges on my account wont show. It wont show in a server for the 3 I have selected, nor will it show in the menu where you select them. They are just default filler images and I don’t know what to do.

Photos below:


1 Like

Can you please post your TeamSpeak 3 Client Log or the TeamSpeak 5 Log.

You can find the Client Log: Tools -> Client Log. Or Ctrl+L.

And you can find also under: C:\Users\your_Username\AppData\Roaming\TS3Client\logs

1 Like

I cannot post the file so here’s the most recent, I have a total of 5 since the 31st:



==================================================================================================================================

2022-11-01 11:29:51.698751|INFO    |              |   |TeamSpeak Client 3.5.6 (2020-11-25 13:53:42)
2022-11-01 11:29:51.698751|INFO    |              |   |SystemInformation: Windows 10 (19045) x64 (AMD or Intel) Binary: 64bit
2022-11-01 11:29:51.699249|INFO    |              |   |Using hardware aes
2022-11-01 11:29:51.760751|DEBUG   |Direct Sound  |   |setting timer resolution to 1ms - 
2022-11-01 11:29:51.824736|INFO    |              |   |*** Time [SPAWN_EVENTCONVERTER]: 127
2022-11-01 11:29:51.906575|INFO    |ClientUI      |   |OpenGL Info: LibGLES, Vendor: Google Inc., Renderer: ANGLE (NVIDIA GeForce RTX 3070 Ti Direct3D11 vs_5_0 ps_5_0), Version: OpenGL ES 2.0 (ANGLE 2.1.0.57ea533f79a7)
2022-11-01 11:29:52.020159|INFO    |Addons        |   |Checking for addon updates...
2022-11-01 11:29:52.066287|INFO    |Plugins       |   |Loading plugin: gamepad_joystick_win64.dll
2022-11-01 11:29:52.114399|INFO    |Gamepad Plugin|   |Found client raw input wnd proc
2022-11-01 11:29:52.114399|INFO    |Gamepad Plugin|   |Cleared device list
2022-11-01 11:29:52.115890|INFO    |Gamepad Plugin|   |Found device \\?\HID#VID_046D&PID_C539&MI_02&COL03#8&5075207&0&0002#{4D1E55B2-F16F-11CF-88CB-001111000030}
2022-11-01 11:29:52.116881|INFO    |Gamepad Plugin|   |Found device \\?\HID#VID_1B1C&PID_1B2D&MI_01#7&37507776&0&0000#{4D1E55B2-F16F-11CF-88CB-001111000030}
2022-11-01 11:29:52.120351|INFO    |Plugins       |   |Loading plugin: teamspeak_control_plugin_win64.dll
2022-11-01 11:29:52.125311|INFO    |ControlPlugin |   |Control Plugin started, accepting connections
2022-11-01 11:29:52.125311|INFO    |Plugins       |   |Loading plugin: clientquery_plugin_win64.dll
2022-11-01 11:29:52.130271|INFO    |Query         |   |listening on 127.0.0.1:25639
2022-11-01 11:29:52.130767|INFO    |Plugins       |   |Loading plugin: AutoFollow_win64.dll
2022-11-01 11:29:52.139199|INFO    |Plugins       |   |Loading plugin: rp_soundboard_win64.dll
2022-11-01 11:29:52.162015|INFO    |Plugins       |   |Loading plugin: NoMove_win64.dll
2022-11-01 11:29:52.171935|INFO    |              |   |*** Time [PLUGINS]: 107
2022-11-01 11:29:52.415968|DEVELOP |Windows Audio Session|   |DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList
2022-11-01 11:29:52.416464|DEVELOP |Windows Audio Session|   |DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList
2022-11-01 11:29:52.458624|DEBUG   |SB            |   |CurrentServerConnectionChanged: 1
2022-11-01 11:29:52.545920|INFO    |              |   |*** Time [MAINWINDOW]: 870
2022-11-01 11:29:52.545920|INFO    |              |   |*** Time [INIT]: 871
2022-11-01 11:29:52.568735|INFO    |ClientUI      |   |Qt version: 5.12.3
2022-11-01 11:29:52.568735|INFO    |ClientUI      |   |Using configuration location: C:\Users\justi\AppData\Roaming\TS3Client\settings.db
2022-11-01 11:29:53.044895|INFO    |ClientUI      |   |Last update check was: Mon Oct 31 14:14:51 2022
2022-11-01 11:29:53.049857|INFO    |Update        |   |Checking for updates...
2022-11-01 11:29:53.055808|INFO    |Bookmarks     |   |Collecting autoconnect bookmarks
2022-11-01 11:29:53.545360|INFO    |Newsticker    |   |Newsticker next check: Tue Nov 1 01:59:06 2022 GMT
2022-11-01 11:30:03.050210|WARNING |ProtobufRPC   |   |Error contacting URL https://clientapi.myteamspeak.com/addon: TIMEOUT
2022-11-01 11:30:03.944994|INFO    |              |   |failed to download accounting revocation list - count: 1
2022-11-01 11:30:04.375522|INFO    |Update        |   |License update available; version 5 to 5 (min version 5 to 4)
2022-11-01 11:30:04.375522|INFO    |Update        |   |Latest client release on channel 'stable': 3.5.6 [Build: 1606312422]
2022-11-01 11:30:04.375522|INFO    |Update        |   |Client is up-to-date
2022-11-01 11:30:04.375522|INFO    |              |   |Statistics report: Not yet, next report on Thu Nov 10 19:10:14 2022
2022-11-01 11:30:04.833330|INFO    |Newsticker    |   |Newsticker received for language en, expires on Wed Nov 2 11:30:04 2022 GMT, next check in 86399 seconds
2022-11-01 11:30:05.396786|ERROR   |SyncImpl      |   |Error requesting account setup: in_process
2022-11-01 11:30:05.396786|ERROR   |ClientUI      |   |Failed to login to account: in_process
2022-11-01 11:30:06.905123|ERROR   |SyncImpl      |   |Error requesting account setup: in_process
2022-11-01 11:30:06.905123|ERROR   |ClientUI      |   |Failed to login to account: in_process
2022-11-01 11:30:14.973557|INFO    |              |   |failed to load static integration list
2022-11-01 11:30:14.973557|INFO    |              |   |failed to download myteamspeak id revocation list - count: 1
2022-11-01 11:30:26.001128|WARNING |ProtobufRPC   |   |Error contacting URL https://clientapi.myteamspeak.com/authentication: TIMEOUT
2022-11-01 11:30:26.001128|WARNING |ClientUI      |   |Account login failed, server currently not available. Retry in few minutes.
2022-11-01 11:30:37.028698|WARNING |ProtobufRPC   |   |Error contacting URL https://clientapi.myteamspeak.com/integration: TIMEOUT
2022-11-01 11:30:37.028698|INFO    |              |   |connection version for integration service not equal - abort
2022-11-01 11:30:48.057759|WARNING |ProtobufRPC   |   |Error contacting URL https://clientapi.myteamspeak.com/addon: TIMEOUT
2022-11-01 11:30:59.085327|WARNING |ProtobufRPC   |   |Error contacting URL https://clientapi.myteamspeak.com/authentication: TIMEOUT
2022-11-01 11:30:59.085327|WARNING |ClientUI      |   |Account login failed, server currently not available. Retry in few minutes.
2022-11-01 11:31:10.114387|WARNING |ProtobufRPC   |   |Error contacting URL https://clientapi.myteamspeak.com/authentication: TIMEOUT
2022-11-01 11:31:10.114387|WARNING |ClientUI      |   |Account login failed, server currently not available. Retry in few minutes.
2022-11-01 11:31:21.727237|WARNING |ProtobufRPC   |   |Error contacting URL https://clientapi.myteamspeak.com/authentication: TIMEOUT
2022-11-01 11:31:21.727237|WARNING |ClientUI      |   |Account login failed, server currently not available. Retry in few minutes.
2022-11-01 11:31:30.237607|DEVELOP |Windows Audio Session|   |DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList
2022-11-01 11:31:30.237607|DEVELOP |Windows Audio Session|   |DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList
2022-11-01 11:31:30.237607|DEVELOP |Windows Audio Session|   |DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList
2022-11-01 11:31:30.237607|DEVELOP |Windows Audio Session|   |DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList

1 Like

Please clear your cache (this folder: C:\Users\USER\AppData\Local\TeamSpeak\Cache) and restart your client.

1 Like

Sounds good, I went through my TS3 Client Log and its saying I cannot connect to both:

11/1/2022 12:08:17	ProtobufRPC	Warning	Error contacting URL https://clientapi.myteamspeak.com/authentication: TIMEOUT	

and 
11/1/2022 12:08:06	ProtobufRPC	Warning	Error contacting URL https://clientapi.myteamspeak.com/addon: TIMEOUT	

Ill try clearing cache now though!

1 Like

I may have to just give it more time, but this has been a problem trying to figure this all out. My connection to the TS servers must be hardly existent cause you can see the profile picture is loading as well as my badges aren’t showing up and the current Halloween badge redeem isn’t loading either. This was after clearing the cache.

1 Like

Then your internet connection is not stable enough or myTeamSpeak may have problems right now. Can’t test it myself if myTeamSpeak is working correctly, as I’m on the phone right now. Just try again tomorrow as today most of the TeamSpeak team is off today due to holiday so they can’t fix problems if there are some on their side.

1 Like

I was hoping and figuring it was a recent connection issue with the servers. Maybe some maintenance or just some type of situational connection issues. I would like to preface that this has literally NEVER been an issue in the past until literally yesterday. It was very random and I guess we’ll just have to see how it plays out. Hopefully all the badges load back and the connection issues resolve themselves.

1 Like

Yeah then is it probably on TeamSpeaks side a server issue.

1 Like

Fingers crossed, I’ll probably just post an update on this thread tomorrow night or something of the sort, but thank you @LeonMarcelHD and @Rikku for the help so far!

1 Like

I doubt that. All services needed for client are fine here.
But my route over Cloudflare to our services may be a different than yours.

4 Likes

Sorry my mistake. :slight_smile:

1 Like

Would you potentially have any more insight? Badges still aren’t showing so I guess ultimately it could be a router or firewall setting on my end but not sure.

1 Like

As long the client can not reach our myTS services, the login, sync etc. will not work.

The services itself are fine. Have your tried a VPN or something else? Maybe nothing local but traffic to our services?

2 Likes
twitch instagram twitter facebook