Teamspeak 5 won't connect to server but ts3 will

Hi, for some reason my newly installed Teamspeak 5 client won’t connect to my server, no matter what i do. The strange thing being that the old client has no issues whatsoever connecting and has a stable connection. My friend also tried to connect and had the same issue so something seems wrong about my server. I can connect fine to the official server.

So far here are the things i have tried:

  • Double checked ports are correctly forwarded
  • Double checked dns settings
  • Tried to connect straight to external ip
  • Read through the logs on both the server and the client
  • Reinstalled new client

The server just says the client is timing out while the client log says the following:

[2022-04-11 01:43:49.675] [info] Initialized with 2 channels in 32bit, 48kHz. - Microphone (Voicemod Virtual Audio Device (WDM))
[2022-04-11 01:43:49.676] [info] Connecting to
[2022-04-11 01:43:49.676] [info] Trying to resolve to
[2022-04-11 01:43:49.684] [info] A/AAAA DNS resolve successful, “” =(h: p:0)
[2022-04-11 01:43:49.684] [info] A/AAAA DNS resolve for possible TSDNS successful, “” =(h: p:0)
[2022-04-11 01:43:49.684] [info] A/AAAA DNS resolve for possible TSDNS successful, “” =(h: p:0)
[2022-04-11 01:43:49.686] [info] SRV DNS resolve unsuccessful, “” DNS server returned answer with no data
[2022-04-11 01:43:49.689] [info] SRV DNS resolve successful, “” =(h: p:9987)
[2022-04-11 01:43:49.692] [info] A/AAAA DNS resolve successful, “” =(h: p:0)
[2022-04-11 01:43:49.693] [info] Connecting to resolved address
[2022-04-11 01:43:49.698] [info] server sent ciphers:1
[2022-04-11 01:43:49.705] [info] Selected cipher:0
[2022-04-11 01:43:51.688] [info] TSDNS queried unsuccessfully
[2022-04-11 01:43:51.688] [info] No TSDNS found
[2022-04-11 01:43:51.688] [info] TSDNS queried unsuccessfully
[2022-04-11 01:43:51.688] [info] No TSDNS found

The address and IP just works fine here. Get asked for a server password.


Does it work on the new client? Cuz for me it still doesnt work. I just get a failed connection initialization in the ui. I dont get asked for a password or anything.

Yes tested with beta 68.1 and newer (non yet released) version.


Do the old client and the new share data somehow? Could some setting or plugin or something made on the old client break the new one?

The TS5 only re-uses the details it got from myTS synced content.

Identity, Bookmark and it’s settings and some hotkeys. And what badges you set as active.


Hmm ok, here is what the server log looks like when the ts5 client connects:

2022-04-11 10:18:43 VirtualServerBase Info client connected ‘Test’(id:528) using a myTeamSpeak ID from
2022-04-11 10:19:14 PktHandler Info Dropping client 66 because of ping timeout 19 0 0
2022-04-11 10:19:14 VirtualServerBase Info client disconnected ‘Test’(id:528) reason ‘reasonmsg=connection lost’

I restarted my computer again and now i get the password prompt but upon entering it i get failed connection initialization again.

According to wireshark the ts5 client sends two messages to the server and then stops responding and the server keeps sending data until eventually it times out. Should i send you the password somehow? I dont feel like putting it on here for everyone to see.

It seems something is wrong with the server configuration, i created a new server and it worked instantly.